none
Can't uninstall Beta language pack RRS feed

  • Question

  • When I try to uninstall the beta version of the language pack it goes a long ways into the install then gives me an error message with error code 2329 and ends the uninstall.

     

    I can't unstall the new language pack because it won't install over the old one and the old one won't uninstall. This leaves me with no working Speech Server installation.

    Tuesday, August 28, 2007 3:36 PM

Answers

  • Marshall & I worked out a workaround for this offline. If you run into this problem, you can uninstall the beta language pack by running

     

    "msiexec /x path_to_language_pack.msi DISABLEROLLBACK=1"

     

     

     

     

    Friday, September 7, 2007 4:12 PM

All replies

  • Hi Marshall,

     

    Sorry to hear you're having a problem with the uninstall. You can get more info about what happened by running the installer with logging turned on:

     

    msiexec /l*v log.txt /x <path_to_lang_pack_msi>

     

    You should then see in log.txt a line with 2329 on it, which will give some more details about the problem.

     

    Error code 2329 is

     

    2329 Error deleting file: [3]. GetLastError: [2].

     

    (There's a table of windows installer error codes here: http://msdn2.microsoft.com/en-us/library/aa372835.aspx)

     

    Take a look at the log, and see what file it can't delete, and why. The GetLastError value will be some number which you can look up in errlook (comes with Visual Studio) that might give you a hint (ie Access Denied).

     

    If that doesn't get you unstuck, please post the relevant section of the uninstall log and I'll see if I can figure it out.

     

     

    Thursday, August 30, 2007 8:08 PM
  • Thanks Edwin.

     

    Here is the relevant part of the log:

     

    MSI (s) (30:C8) [19:02:10:504]: Executing op: FileRemove(,FileName=tel_host_us_jill_full_encrypt.hdr,,ComponentId={FC300DF8-8194-4F3E-90CD-10ED2CE3106D})
    MSI (s) (30:C8) [19:02:20:507]: Note: 1: 2329 2: 32 3: C:\Config.Msi\23a28c2.rbf
    MSI (s) (30:C8) [19:02:20:507]: Note: 1: 2205 2:  3: Error
    MSI (s) (30:C8) [19:02:20:507]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 2329
    DEBUG: Error 2329:  Error deleting file: C:\Config.Msi\23a28c2.rbf. GetLastError: 32
    MSI (s) (30:C8) [19:02:31:403]: Note: 1: 2205 2:  3: Error

     

    I've given the account I'm logged in as full rights to the directory but it still won't work.

     

    Any suggestions.

    Thursday, August 30, 2007 11:08 PM
  • Error code '32' means 'The process cannot access the file because it is being used by another process.'

     

    There are 2 possibilities:

    1) another process does actually have the file open. You could check for which one with Process Explorer.

    2) I've also seen this when a file is in a 'pending deletion' state - it was deleted but some process had a handle open on it.

     

    For either case, my first suggestion would be:

    1) make sure speech server isn't running (if it's not installed, of course it won't be)

    2) reboot

    3) stop the service if it got restarted

    4) try uninstalling again.

     

    You could also try deleting the file by hand. Typically the uninstall won't be upset if a file is already gone.

     

    Hope that helps.

    Thursday, August 30, 2007 11:34 PM
  • Speech Server isn't installed.

     

    I've deleted the file by hand.

     

    In fact I've deleted every file in the directory and it still won't work. The file appears to be created by the uninstall program.

     

    Friday, August 31, 2007 12:12 AM
  • This is an odd one. I've never seen this problem crop up before :-(

    The config.msi directory is, as you say, managed by Windows Installer - it uses it for temporary storage while running installers. I will need to do a bit of research as to what might be going on. In the meantime, I have one speculative suggestion - if you have a virus scanner running, you might want to temporarily disable it while doing the uninstall. That's admittedly kind of a long shot, but I have occasionally known virus checkers to interfere with temporary files which are only created for a short time.
    Friday, August 31, 2007 4:43 AM
  • Yeah, it's odd. I don't go for the average problems. :-)

     

    I tried turning off the virus software (Nod32) but that didn't help.

     

    This is on a Vista Ultimate box and I give the uninstall permission to run. Just not sure why this is happening but it is keeping me from doing any development.

     

    Friday, August 31, 2007 12:31 PM
  • Marshall,

     

    Sorry for the delay. I'm talking to some of the installer folks here. Could you send the entire verbose install log? Either post it here or mail to edwin dot young at microsoft dot com.

     

    Thanks!

     

    Wednesday, September 5, 2007 5:33 PM
  • Edwin,

     

    I've emailed you the log file.

     

    Thanks.

     

    Marshall

     

    Thursday, September 6, 2007 2:36 PM
  • Marshall & I worked out a workaround for this offline. If you run into this problem, you can uninstall the beta language pack by running

     

    "msiexec /x path_to_language_pack.msi DISABLEROLLBACK=1"

     

     

     

     

    Friday, September 7, 2007 4:12 PM