none
Windows 7 libraries, 2nd level folders & WHS RRS feed

  • Question

  • Hi,
     I just installed my WHS (HP EX490) 2 days ago and have been copying data across from an old NAS.

    The clients are a mix of XP x32 and Win 7 x64

    I have a series of users such as "Nigel" defined in WHS, and underneath this directory have the usual "Documents", "Pictures" etc
    The actual share in WHS appears to be "Users"

    In Win 7 libraries I CAN add "\\cherrystore\Users\Nigel" to a library (ie Documents)
    but
    CANNOT add "\\cherrystore\Users\Nigel\Documents"

    getting an error "This network location can't be included because it is not indexed"

    I did check using remote desktop that Nigel is indexed - in fact in whs "c:\shares" is indexed. I tried adding "c:\shares\Nigel\Documents" but it made no difference.

    I had thought PP3 correctly supports Win7 libraries -- this seems like an omission.

    My choices appear to be
     * Create an "offline" copy -- don't want to do this as the folders are many 10s Gb
     * Just add the top level dir -- but then I get docs, pictures, photos all mixed up
     * Create a new share ie "Nigel" - this probably will work but defeats the object of the "Users" share. Perhaps this doesn't matter

    In summary it appears only the subfolder of a share, or share itself can be added, not a second level folder

    I'm inclined to take the last option, but it does seem a little "silly". This seems such an OBVIOUS use case for use of libraries with WHS?
    Sunday, December 27, 2009 11:41 AM

Answers

  • Indexing completed overnight, and I was then able to add any folder I wanted! So working as I expected now.

    So this was a simple indexing issue, but
     * The link between WHS, indexing & locations wasn't entirely clear
     * The indexing appeared to be very conservative in pausing (too much so IMO)

    Will have to keep an eye on indexing & possible tweak the Backoff settings.

    Thanks
    Nigel.
    Monday, December 28, 2009 10:37 AM

All replies

  • Just out of curiosity, why "c:\shares" instead of "d:\shares."  Is that a typo?  All shares on WHS should be created through the WHS Console and will appear as the "d:\shares\xxxxx" variety.  I have successfully added multi level deep shares from WHS to the W7 Library.  Could you provide more details on how you created your shares on WHS and the how you attempted to add the shares to the WHS Library?
     
    --
    ______________
    BullDawg
    Associate Expert
    In God We Trust
    ______________
     
    "planetf1" <=?utf-8?B?cGxhbmV0ZjE=?=> wrote in message news:fb2a5d8b-8834-42c 2-bd2b-d5390a92a74f...
    Hi,
     I just installed my WHS (HP EX490) 2 days ago and have been copying data across from an old NAS.

    The clients are a mix of XP x32 and Win 7 x64

    I have a series of users such as "Nigel" defined in WHS, and underneath this directory have the usual "Documents", "Pictures" etc
    The actual share in WHS appears to be "Users"

    In Win 7 libraries I CAN add "\\cherrystore\Users\Nigel" to a library (ie Documents)
    but
    CANNOT add "\\cherrystore\Users\Nigel\Documents"

    getting an error "This network location can't be included because it is not indexed"

    I did check using remote desktop that Nigel is indexed - in fact in whs "c:\shares" is indexed. I tried adding "c:\shares\Nigel\Documents" but it made no difference.

    I had thought PP3 correctly supports Win7 libraries -- this seems like an omission.

    My choices appear to be
     * Create an "offline" copy -- don't want to do this as the folders are many 10s Gb
     * Just add the top level dir -- but then I get docs, pictures, photos all mixed up
     * Create a new share ie "Nigel" - this probably will work but defeats the object of the "Users" share. Perhaps this doesn't matter

    In summary it appears only the subfolder of a share, or share itself can be added, not a second level folder

    I'm inclined to take the last option, but it does seem a little "silly". This seems such an OBVIOUS use case for use of libraries with WHS?

    BullDawg
    Sunday, December 27, 2009 6:26 PM
  • The server is running PP3.

    The shares in question are those automatically created when a user is added. In this case I added user "Nigel", so this can be accessed as \\server\users\Nigel . This was all done through the WHS console

    The actual indexed location (checked, not modified) is indeed d:\shares -- I had made a typo!

    The actual "share" appears to be \\server\users

    When using Windows 7 (x64, with updates) libraries
    \\server\Users\Nigel - can be added
    \\server\Users\Nigel\Documents -- cannot be added

    I had thought the issue was with 2nd level directories, so I checked with the automatically created "Music" folder -- I *WAS* able to add many directories deep to the library just fine..

    I then made a NEW SHARE "Nigel.home" accessed as \\server\Nigel.home & copied files (using UNC paths) across from the original directory. I cannot add ANY directory, even the top level to the library. So it's possible there's a delay factor here, although the WHS syste, has idled for quite a few hours now and is running near 0% ...

    So now I'm a little confused...
    Monday, December 28, 2009 1:23 AM
  • Additional info

    The files were originally copied via

    robocopy /mir \\oldnas\oldshare \\server\users\Nigel 

    (same for all data)

    This was run on an attached PC, so all running via UNC

    This user has full read-write access to the tree
    Monday, December 28, 2009 1:27 AM
  • I should add that the Windows Search 4 update (and all others) from Windows Update has been installed
    Monday, December 28, 2009 1:32 AM
  • And tested a little more with a share (created via WHS console) "download"

    I could add \\server\download as a location
    I could NOT add \\server\download\newdir

    This occurred for a variety of different directories

    So some inconsistency here. Wonder if this is index lag? 
    Is there a way to
     * monitor indexing progress
     * temporarily force the index to run at higher priority 

    Or is there something else at work? permissions? Is there something "special" about the predefined "Music" (which works)?
    Monday, December 28, 2009 1:38 AM
  • Ok, think I found the culprit. I had 8000 of 100'000s files indexed. It appeared index was stalled due to I/O, not that I could see any....

    I eventually decided to disable the "backoff" setting in Windows Search 4, directly via remote desktop in WHS, restarted indexing service and now files are being indexed rapidly.

    I'll plan to revert once the initial mass indexing is complete.

    I have a feeling this is the explanation.
    Monday, December 28, 2009 2:01 AM
  • I believe you are on the right track.  I just got in from work and was reading through the thread and starting thinking, "Sounds as if this is an indexing problem."  Keep me posted, but I think you have it resolved.  Sometimes, I snooze indexing for a day, but then forget I did it.

    --
    ______________
    BullDawg
    Associate Expert
    In God We Trust
    ______________
     
    "planetf1" <=?utf-8?B?cGxhbmV0ZjE=?=> wrote in message news:c553fcfd-1f5a-4eb 5-b939-91ecfa51ff6b...
    Ok, think I found the culprit. I had 8000 of 100'000s files indexed. It appeared index was stalled due to I/O, not that I could see any....

    I eventually decided to disable the "backoff" setting in Windows Search 4, directly via remote desktop in WHS, restarted indexing service and now files are being indexed rapidly.

    I'll plan to revert once the initial mass indexing is complete.

    I have a feeling this is the explanation.

    BullDawg
    Monday, December 28, 2009 9:08 AM
  • Indexing completed overnight, and I was then able to add any folder I wanted! So working as I expected now.

    So this was a simple indexing issue, but
     * The link between WHS, indexing & locations wasn't entirely clear
     * The indexing appeared to be very conservative in pausing (too much so IMO)

    Will have to keep an eye on indexing & possible tweak the Backoff settings.

    Thanks
    Nigel.
    Monday, December 28, 2009 10:37 AM