locked
System Administrator Has Limited Access RRS feed

  • Question

  • I am logged into CRM with an account that was used to deploy CRM 2011. That account is the Deployment Manager and has System Administrator access. However, a few strange things are happening:

    * I have a console application that uses that account to access CRM. However, I get an error when I try to retrieve data. The error is not descriptive but it seems to be an access right problem.

    * When I use the Plugin Registration Tool and log in with this account from a remote computer I get an error, probably again due to access right issues. However, when I do the same on the CRM server everything works fine.

    Note that I did user PowerShell to set "Send As" and "FullAccess" rights on all accounts for the Email Router. I think this only influenced mail access rights but I am not 100% and there is a possibility this caused the current issue.


    • Edited by hfaun Tuesday, September 16, 2014 8:50 PM
    Tuesday, September 16, 2014 8:33 PM

All replies

  • It turns out crmsvcutil also fails. It says "Exiting program with exception: The content type text/html; charset=utf-8 of the response message toes not match the content type of the binding.... My console application gives me the same error. It's also the same error when I enter a wrong password, hence it seems something fails before the actual authentication. Also as mentioned, the plugin registration tool works on the crm server so somehow I cannot get through from the outside (but with the same account I can log into CRM, create records, create users, etc).

    Tuesday, September 16, 2014 10:21 PM
  • hi,

    looks like you ticked all the boxes and still have issue. See if the current user is in privuser group? Can't think of anything else.

    regards,

    Jithesh

    Tuesday, September 16, 2014 11:11 PM
  • Jithesh, the account was not a member of PrivUserGroup. I added that as well as PrivReportingGroup and SQLAccessGroup. The other two I found in SQL Server Management Studio under MSCRM_CONFIG->Security->Users. However, this did not help.
    Wednesday, September 17, 2014 3:06 PM