locked
Report server error - can not access data source RRS feed

  • Question

  • hi,

    I have report error In CRM

    Below are my evironment

    1. CRM and sql server are intalled in two different servers

    2. SQl server and reporting services are on the same server

    3. I am using SQL server 2008

    4. Data connector is installed on sql Server

    5. I am using IFD + promise deployment

     

    - I have already check the networkservice account on the sql server and it has the righ permission

    - Before i install crm the sql server was running outside the domain and when server join the domain the compurter name was changed. i have already change the instance name in the sql server to the new compurter name

    - I can run the reporting service url from internet explorer

     

    Below is the error

    Error Description:

    An error has occurred during report processing. (rsProcessingAborted)


    Error Details:

    An error has occurred during report processing. (rsProcessingAborted)


    Full Stack:

    [ReportServerException: For more information about this error navigate to the report server on the local server machine, or enable remote errors]
    
    
    [ReportServerException: Cannot create a connection to data source 'CRM'. (rsErrorOpeningConnection)]
    
    
    [ReportServerException: An error has occurred during report processing. (rsProcessingAborted)]
      at Microsoft.Reporting.WebForms.ServerReport.SetDataSourceCredentials(DataSourceCredentials[] credentials)
      at Microsoft.Crm.Web.Reporting.SrsReportViewer.SetExecutionCredentials(ServerReport report)
    
    [CrmReportingException: An error has occurred during report processing. (rsProcessingAborted)]
      at Microsoft.Crm.Web.Reporting.SrsReportViewer.SetExecutionCredentials(ServerReport report)
      at Microsoft.Crm.Web.Reporting.SrsReportViewer.ConfigurePage()
      at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
      at System.Web.UI.Control.PreRenderRecursiveInternal()
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    
    [HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]
      at System.Web.UI.Page.HandleError(Exception e)
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest()
      at System.Web.UI.Page.ProcessRequest(HttpContext context)
      at ASP.crmreports_rsviewer_reportviewer_aspx.ProcessRequest(HttpContext context)
      at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
      at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    
    
    Pleas help
    Thanks
    Marwa Saleh
    Thursday, August 19, 2010 4:10 PM

Answers

  • Ok, if you can not run reports from the report server, then you need to troubleshoot the report server to see what is wrong.  Have a read through the article Microsoft Dynamics CRM Reporting Top Issues and Troubleshooting.  This should have all the information needed to identify what is wrong with your installation.

    Regards, Donna

    • Proposed as answer by Donna EdwardsMVP Friday, August 20, 2010 1:12 PM
    • Unproposed as answer by Marwa saleh Friday, August 20, 2010 1:54 PM
    • Marked as answer by Marwa saleh Friday, August 20, 2010 2:18 PM
    Friday, August 20, 2010 1:12 PM
  • hi,

    I found the solution.

    I just need to make restart to the reporting service. before restart I did repair in crm server and re install the SRS connector

    Thanks

    Marwa Saleh

    Friday, August 20, 2010 2:20 PM

All replies

  • Have you looked through this Microsoft article.

    It looks like the report's datasource was not registerd correctly (possibly) since it is looking for the datasource 'CRM'.  CRM is not the shared datasource used by the CRM reports.  It should be something like "MSCRM".  You can check the datasource used by the report by navigating to the Report server, select Edit for the report and select datasource from the left navigation menu.


    Regards, Donna

    Thursday, August 19, 2010 4:38 PM
  • hi,

    thank you for your replay. I have check the report datasource and if uses the MSCRM_Datasource under 4.0 folder.

    however the data source is using external connector string in the connection string.

    Also I want to mention that i have installed crm berfore in the same servera and unistall the server and the srs connector. and install them again

    I have read the article but all the hot fix mention that they were fixed int he lates rollup update

    Thanks

    Marwa Saleh

     

    Thursday, August 19, 2010 6:06 PM
  • Ok, that sounds right.  Can you run the report from the report server?  Are you having a problem with all reports or just this one?

    Regards, Donna

    Thursday, August 19, 2010 11:05 PM
  • hi,

    I am having error with all crm reports. and I can not run the reports from the rport server.

    Thanks

    Marwa Saleh

    Friday, August 20, 2010 1:41 AM
  • Ok, if you can not run reports from the report server, then you need to troubleshoot the report server to see what is wrong.  Have a read through the article Microsoft Dynamics CRM Reporting Top Issues and Troubleshooting.  This should have all the information needed to identify what is wrong with your installation.

    Regards, Donna

    • Proposed as answer by Donna EdwardsMVP Friday, August 20, 2010 1:12 PM
    • Unproposed as answer by Marwa saleh Friday, August 20, 2010 1:54 PM
    • Marked as answer by Marwa saleh Friday, August 20, 2010 2:18 PM
    Friday, August 20, 2010 1:12 PM
  • hi,

    Sorry to mark it as unanswer.

    I have publish crm report for external use and I am able to run the report from reporting server

    Can the problem be in the IFD deployment becuase the datasource is using "MSCRM Data Connector Connection String"

    the server name include "-" can this cuase error

    Thanks

    Marwa Saleh

     

    Friday, August 20, 2010 2:00 PM
  • hi,

    I found the solution.

    I just need to make restart to the reporting service. before restart I did repair in crm server and re install the SRS connector

    Thanks

    Marwa Saleh

    Friday, August 20, 2010 2:20 PM
  • great, I'm glad it is working!

    Regards, Donna

    Friday, August 20, 2010 2:30 PM