locked
Communicator 2007 client issue RRS feed

  • Question

  •  

    I've setup an Office Communicator 2007 environment.  It's setup and working appropriately.  Remote access functionality works.  The issue I have is our Security department doesn't want this feature to be avaiable to anybody.  They only want instant messaging to function when a user has logged in throug our VPN.  The problem is that when a user logs into a laptop off of our corporate network the client attempts to connect and can't.  So the client comes up with the username and password prompt.  If you then connect to the vpn the client still behaves that way for a period of time requiring you to enter your credentials unless you totally exit out and open it back up.  At that point the client attempts to discover it's location and can successfully connect.  Is there anyway of changing the client behavior? 

     

    My understanding of how the client works is that when it's configured to start when you log onto your computer the client attempts to discover the OCS server internally through DNS SRV records, it can't so it attempts to connect from externally through DNS SRV records, and if that doesn't work the client pops up asking for a username and password.  If a user is enabled for remote access it the client connects fine from externally, but as I said before our security department doesn't want the functionality for users.

     

    Can the client be configured to reattempt the negotiation process more frequently (i.e 1 minute) or something along that line?  Any help would be much appreciated.

    Wednesday, July 23, 2008 4:35 AM

All replies

  •  

    I do not believe you can change the behavior or when the client tries to authenticate/query dns.  But you could push Manual configuration via GPO.  That way they dont try DNS.

     

    -geoff

    Sunday, July 27, 2008 6:54 PM