locked
Trouble setting up router for web access RRS feed

  • Question

  • Hey Gang,

    First off...I'm completely new to using server software.  I have been building my own machines for about 16 years, so I'm competent on the OS side, but by no means even close to proficient with Home Server.

    I just built a server with WHS 2011 and am having a problem with the router set-up wizard to turn remote access on.  It came back saying there might be two routers, which there are.  I run from the Qwest/Century Link DSL router to my Netgear WNDR 3700 which I use because it has better wireless, etc, etc.  I've checked on the Netgear, and upnp is on and port 443 is forwarded.

    Any suggestions on this?

    Thanks!

    Wednesday, November 16, 2011 1:37 AM

All replies

  • It will probably be easier to do this manually (switch off UPnP) and how you do this depends where your Server is located. If it's connected to the router closest to the Internet, route Port 443 (and optionally Port 80) to your Server IP address. If it's connected to the other one, route those ports above from the outer router to the IP address of the inner router and on the inner, route the ports to your Server IP address.

    Use ShieldsUp at www.grc.com to confirm the ports are open.

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Wednesday, November 16, 2011 1:43 AM
  • Okay...still no luck.

    Qwest router is 192.168.0.1

    Netgear is 192.168.1.1

    Server is 192.168.1.14

    I forwarded both ports in the Qwest router to 192.168.1.1.  Then in Netgear router to 192.168.1.14.  Turned off upnp.  ShieldsUp showed everything came back as stealthed...if I did the test right.  I upgraded the firmware on the Qwest router, the Netgear was up to date.

    I'm still getting the original "2 routers" warning.  Now I'm also getting a "upnp is disabled on your router" and "ports aren't forwarding" warnings...won't complete.

    DHCP is enabled on both routers, not sure if that matters or not.

    Any ideas?

    Thank a ton!

    Wednesday, November 16, 2011 3:33 AM
  • Well, I'm a little further along.

    I was able to put the Qwest router into bridge mode and PPP in from the netgear.

    The Remote Access wizard actually sees the Netgear now, but I'm getting a new error.  It says ports not forwarded correctly.  I have the server assigned to 192.168.1.14 in the netgear and have forwarded ports 443 and 80 to that server IP.  Also, that's with upnp turned on.  If i turn upnp off the error changes to your device doesn't have upnp.

    If I turn on upnp and don't forward the ports, it says there is no internet connection...even though I can browse on that machine.

    Thoughts anyone?

    Thursday, November 17, 2011 6:33 PM
  • I suspect this is because you've got two routers on different subnets.  You're wanting to port forward certain traffic from the first router, but your server is connected to the second and I suspect the port forwarding is getting extremely confused.  There are two fixes I can think of to do this:

    1) Set up static routes on your Qwest router to ensure traffic going to the 192.168.1 subnet goes to your Netgear router, and vice versa for the 192.168.0 subnet.  This may or may not be possible depending on firmware.

    2) Set your Netgear router to be an access point and connect the cable from the Qwest router to one of the LAN ports.  Then make sure all the devices are in the same subnet.

    The second option is far, far simpler.  Most home users have no need for multiple routers or subnets.  Keep it simple!

    I have two routers on my network too, to provide two different wireless networks (a long story - ask me if you really want to know!) and I've set one to be an access point, and it all works just fine.

    Thursday, December 1, 2011 4:05 PM