none
Cached credentials are not working on the lock screen (Windows 7)

    Question

  • Hello all,

    We are having a difficult time trying to troubleshoot a problem with credential caching seemingly not working on the lock screen for our laptop users. Users are instructed to logon to the laptop while connected to the domain to cache their credentials. The user then leaves the network, and is able to log in to the laptop using cached credentials. The laptop locks either due to a manual lock, or due to an inactivity timer. The user tries to relog and is presented with the error “no logon servers available to service the request.” Users are reporting the problem from both home and public networks. We have been able to recreate the issue by logging on the laptop while in the office and setting our internal wireless network to manually connect, and then simply clicking start > shutdown arrow > lock. Many users have reported that they were able to get back into the laptop after a hard shut down, but would be unable to log in again if they returned to the lock screen. One user has reported that selecting other credentials > switch user > other user while on the lock screen and then entering in his DC credentials would allow him to get back into the laptop. I was unable to recreate this workaround on our test machine. I also tried to logon using the switch user account with the “.\username” method to see if that would look for cached credentials. One user has reported that he was unable to hard shut down the computer to get back in. He also reported that he tried to pull the battery and give it time before trying again.

    We have set the value for “Interactive logon: Number of previous logons to cache” to 50. The status of “Interactive Logon: Require Domain Controller to unlock workstation” is disabled. We have tried to turn the Wi-Fi switch off and then back on while on the lock screen. Error logs that we think are related to the problem include – Event ID:5719, NETLOGON and Event ID:4343, NlaSvc error 0x4C6 and error 0x51

    I have a slightly sinking feeling it has something to do with NLA thinking that they are connected to a domain while on the lock screen, but this is pure speculation. Thanks for reading my post and any potential solutions are greatly appreciated! 

    • Moved by Mike Kinsman Friday, October 10, 2014 5:01 PM off topic for site feedback, moving to what forum so you dont have to retype all of this
    Friday, October 10, 2014 2:39 PM

Answers

All replies