Redeployment Error RRS feed

  • Question


    I am migrating my CRM3.0 database and server to a new domain.

    I have installed SQL on the new server, and restored a copy of the live DB.

    I have then ran the Redeployment Wizard to map the users.

    Then, when I try to install CRM Server, I get the error..

    Action Microsoft.CRM.Setup.Server.AddLicenseAction failed. Exception HRESULT: 0x80040216

    I have made sure that I removed the current rows in the License table.


    Monday, November 19, 2012 6:13 PM

All replies

  • Hi, I have been working with CRM since the version 1.2 (2004) until now (CRM 2011), and I have made a lot of redeployments, and upgrades, and I never deleted on row of any table when I have to do a redeployment or upgrade. I think that the error that you are experiencing is because of that, I should never delete any row when you are doing upgrades or redeployments. The objective of the redeployment is to update the guid's for the new environment in this case for the new active directory users. Kind regards, Pedro Airo CRM Architect
    Monday, November 19, 2012 8:51 PM
  • Thanks Pedro.

    I'm sure I tried it without deleting the license record, but I'll give it another go.

    Our live environment has two separate licenses installed, but when I try to redeploy, it will only accept one or the other, not both. Do you think I should delete one record, and retain the license I am redeploying with, or just leave both records in the table?

    Monday, November 19, 2012 8:57 PM
  • Hi,

    As i remember when I did the redeployments, my steps were:

    backup the databases 

    restore the databases into the new environment

    run the redeploy tool with a user with the previleges to access and write into the AD, admin of the SQL and CRM servers

    the last step was run the CRM installer with a valid licence key

    i understand that because of you are saying you have a NLB configured into the production, so try first like I said, without removing any rows of the licence table, if not work, try then removing one.

    if possible give a read into the crm3.0 implementation guide, you should have there relelevant information.

    Kind regards,

    pedro airo

    Monday, November 19, 2012 9:13 PM
  • Hi Pedro,

    I have tried both, and still get the same error.

    Looks like I'm going to have to hire someone to do it for us.

    Thanks for your help


    Monday, November 19, 2012 10:19 PM