Upgrading from 8.1 to 10 tripped my CD/DVD Drive? RRS feed

  • Question

  • Hoping this is the right forum. I'll let you know what's happened and then maybe its good for you experts or you can point me in the right direction. Thanks.

    I have a small but effective HP Pavilion20 desktop that came with Windows 8. and upgraded to 8.1 within the 1st couple of days out of the box. For the most part everything has been very good. Almost Great. I'm realizing now that I've should have chosen a machine with a higher performance format due to that this little guy gets a work out but I'm careful and quite ginger with the load I put on it. I'm a photographer/musician and use a couple of different photo shops and download and burn quite a bit of music sometimes at the same time without ever overworking this PC. I have a "On Top Of Screen" RAM% and CPU% monitor that I can see to watch the levels and slow down if needed. But if I were running both the photo editing and downloading, or burning, everything would be running pretty warm and I would then back off if it ran hot. Which, is no way to have fun whatsoever and I dislilke this situation and need a bigger system, I know. I want to fix this little champ for my daughter and upgrade my gig.  Ok well right after, within an hour after I switched from Windows 8.1 to 10, I noticed that the CD drive was taking a little longer than usual to read the CD I had just put in the drive. It was about a full minute and then it finally found it and things were cool. At that very moment I received a pone call and paused it, not downloading yet. But when I hung up the phone that was all she wrote, the 1st CD in Windows 10 was its last and still hasn't played since. That was the last CD my Microsoft provided "hp DVDRAM GT80N" Driver, version 10.0.10240.16384 in Windows... now 10 read. At first, when the upgrade was complete, I toured around ooo'in and aahh'in and then went back to work, edited a few photos and decided to download that disc and this time it didn't take. It's like the machine is trying and trying to read it and honestly doesn't stop trying to read the CD, I have to manually eject, which is not good, I know, but the longest time I would let it go while contiuously tried and tried to read the CD was near an hour and I had to manually eject, I've performed a handful of more attempts but then just stopped to prevent any further damage, each time was a manual eject. The screen would freeze, but "Only" on the CD Player and It would not let me click on anything at all, the curser was the only thing moving but I could click on the tool bar below to get out and click on everything else with no problems. I can move to any other window outside the player and everything was working normally, It didn't slow my browsing and searching and even photo editing at all. I went through many troubleshoots with no luck because once again it believes it is "working properly".  I swear if I see those two words one more time, something else will become broken, hahaha, no not really. But it becomes frustrating.  And wouldn't you know it, "Fix it" isn't quite supported yet here on Windows 10. Properties says the device is working properly and I can assure it is not! I want to uninstall and reinstall but the dang computer, it believes the CD/DVD Drive is working properly and doesn't think I need to do such a thing and wont let me. Talk about a bug, holy moly.  So its weird as heck but I've now been at this for 4 solid days and I now need help and answers.  Isn't there any way I could uninstall and reinstall the E: Drive, no clue what to do any more. I've searched high and low and this seems to be pretty unique. The computer believes its reading it fine but it will not read any type of CD I put in, I've tried all types. Not sure if it will write, I feel I've should ask first before I proceed. I was determined to find a way to fix it but am now throwing in the white towel.  I...   give, .....Uncle.    The upgrade did the CD/DVD Drive in.  Is there a chance Microsoft will work with me on this?  Or is there a way I can uninstall and reinstall with no costs?  "Just Wondering" if there is a case here for a new CD/DVD Drive. The warranty was literately up 4 months ago, this little tiger still feels brand new. but if I must I could meet Microsoft 1/2 way. Please let me know. Thanks everybody!! I'll be looking forward to your expert opinions.

    Again, working with a

    HP Pavilion20 All-in-One with Windows 10, and a Microsoft provided "hp DVDRAM GT80N" Driver, version 10.0.10240.16384

    • Edited by deepurpleasure Monday, August 10, 2015 4:39 PM needed to write the make of the drive down at the bottom one more time
    Monday, August 10, 2015 4:29 PM

All replies

  • Good mornin'

    Problem: Windows 10 Does not recognize a blank writable DVD or CD

    Operating System: Operating System: Windows 10 Pro 64-bit (10.0, Build 10240) (10240.th1_st1.151104-1714)

    CD/DVD Burner: ASUS drw-24F1ST,Driver:MicroSoft  Date:6/21/2006 Driver Version: 10.0.10240.16384  Working well under Win7.

    Clean install (c:\ formatted ect) of Windows 10 to the newly formatted C:\ and the CD/DVD drive is not recognized by the OS.

    I Applied the registry hack found here:   http://www.askvg.com/optical-drives-are-not-showing-in-my-computer/

    This is the registry location here ( be really really in the registry careful folks!! )  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}


    The drive, after a re-boot still  did not recognize the drive with a BLANK writable DVD mounted. However it DOES recognize a disk with previously burned files written to it.

    So . . . It boots a bootable disk but can't find a perfectly good brand new BLANK writable disk.

    I opened THIS PC and RIGHT clicked on the DVD drive bringing up a menu where one of the selections is Format. Hmm . . 

    Clicking on Format another menu allows you to set a File System, Allocation Size and a Volume Label . . . . Which I did. VOILA! FIXED!! It seems to OS want's a FORMATTED DVD? mounted. WHAT? That never was the case under previous (all of them) OS so what's going on here?

    Double clicking on the drive Icon in MY PC brings up the drive in a Drive Tools Manage window showing a blank drive. I was able to drag and drop files (I used my backup Long Island Rail Road backup *.rar files ( size about 1.2 Gig ) as a test as well as other various files I wanted hard copy backups. All burn tests to the drive both CD-R and DVD worked as expected.

    Bottom Line: It 'seems' like the system 'wants' a formatted? DVD mounted where previous operating  systems DID NOT!!!  This seems at odds with what I and apparently many others have come to expect of their well running systems, namely that the system I/O works as it did on the systen they just upraded to W10 . . .which I see now as a 'Work in Progress' :)

    Best regards, Vince Cockeram 

    • Edited by vcockeram Sunday, November 15, 2015 4:35 PM registry warning added
    Sunday, November 15, 2015 4:30 PM