locked
Live Mesh Mobile Install RRS feed

  • Question

  • I have the cab file and started the install. 

    The install stopped with an Unsatisfied Dependency error. Live mesh was unable to find a suitable version of sql ce on this device.

     I have never had this error before installing.  I googled but to no avail.  I have the HTC TyTn II, (tilt).  The list in the sticky says it should work.  I am running a cooked 6.1 rom. 

    What other program do I need to get this to work?
    • Edited by Inajam Thursday, October 30, 2008 9:35 PM
    Thursday, October 30, 2008 9:33 PM

Answers

  • Hello everyone,

    Check this thread for updates. I will definately update the current thread with a resolution the minute we have it.

    Thanks,
    Archis
    A Jedi in the making!
    Friday, October 31, 2008 5:27 PM

All replies

  • I got that error too.  Installed SQL Server CE 3.5 and it still has the error.
    Thursday, October 30, 2008 9:35 PM
  • I am having the same problem.   I went and installed SQL CE 3.5 SP1 and the 3.5 SP1 SQL client, and still have the same issue.

    Thursday, October 30, 2008 9:48 PM
  • I get all excited and then this happens.  For those who have the cab to install what phone/rom are you using.  Is it because I am using a cooked rom or are those that are using AT&T's stock rom's also getting this error.  
    Thursday, October 30, 2008 9:56 PM
  • I'm having this same issue, and I've installed 3.5 core. It has no effect.
    Thursday, October 30, 2008 10:38 PM
  • Hello,

    This is a known problem we've seen with devices that were flashed with 6.1 later. The Mesh mobile client requires SQL CE replication services along with the core.

    If you installed SQL CE from a cab file named sqlce.<something?.cab, you should find an accompanying cab that's named sqlce.repl.<something>.cab along with it. If you're installing from an MSI, then this cab will be located in the same folder as the sqlce.<platform>.<processor>.cab.

    Let me know if this helps.

    Thanks,
    Archis
    A Jedi in the making!
    Thursday, October 30, 2008 10:53 PM
  • I believe that I have installed the correct files.

    Following this guide http://msdn.microsoft.com/en-us/library/13kw2t64.aspx

    I went to this file location C:\Program Files\Microsoft SQL Server Compact Edition\v3.5\Devices\wce500\armv4i
    and  I installed the sqlce.repl.ppc file, sqlce.ppc file, and the sqlce.dev.enu.ppc  files. I installed the ppc version because I have a TyTnII. 

    They all installed properly, at least I didn't get an error. 

    I then tried to install live mesh and recieved the same error. 

    I performed a soft reboot and tried again with the same error.


    Friday, October 31, 2008 12:16 AM
  • I have a cooked 6.1 ROM as well running ATT Tilt and I have the same issue. I have all the necessary SQL CE dependencies installed (including replication).

    Hence, as Inajam suggest - this may be either a TYTN II issue or a cooked WM6.1 ROM issue...
    Friday, October 31, 2008 2:51 AM
  • I have also installed the SQLCE.repl (PPC version) cab on my HTC Mogul (Titan), and I get the same "missing SQL dependency" error.
    Friday, October 31, 2008 3:42 AM
  • I installed both the core and the repl cabs and am still experiencing the same issue.  I am also using a "cooked" WM6.1 ROM but on a T-Mobile Wing (a rebranded HTC).  
    Friday, October 31, 2008 6:16 AM
  • An updated version has been released and the login works. I installed and logged in successfully (att tilt, std 6.1 rom), without needing any additional sqlce cabs (I had .net 2/3.5 installed for a while).

    chrz
    Friday, October 31, 2008 6:25 AM
  • I have tried installing the latest version posted on the Live Mesh blog and I get the same SQL error - "Unsatisfied Dependency."
    Friday, October 31, 2008 7:16 AM
  • Running into this as well, and have installed SQL CE 3.5 SP1 to PC from http://www.microsoft.com/downloads/details.aspx?FamilyId=FCE9ABBF-F807-45D6-A457-AB5615001C8F&displaylang=en, then installed the core & repl CABs from the PC install on my WM 6.1 device. I can see both "SQLServerCompact 3.5 Core" and "SQLServerCompact 3.5 Repl" in "Remove Programs" on the device.

    Still run into "...unable to find a suitable version of SQL CE on this device" when installing livemesh.cab.

    Is there an installation log we can look at to help?
    Friday, October 31, 2008 10:49 AM
  • I have got same error, can anybody help me?
    Friday, October 31, 2008 1:02 PM
  • Inajam said:

    I believe that I have installed the correct files.

    Following this guide http://msdn.microsoft.com/en-us/library/13kw2t64.aspx

    I went to this file location C:\Program Files\Microsoft SQL Server Compact Edition\v3.5\Devices\wce500\armv4i
    and  I installed the sqlce.repl.ppc file, sqlce.ppc file, and the sqlce.dev.enu.ppc  files. I installed the ppc version because I have a TyTnII. 

    They all installed properly, at least I didn't get an error. 

    I then tried to install live mesh and recieved the same error. 

    I performed a soft reboot and tried again with the same error.


    +1


    Like I Care...
    Friday, October 31, 2008 2:51 PM
  • Hello everyone,

    Check this thread for updates. I will definately update the current thread with a resolution the minute we have it.

    Thanks,
    Archis
    A Jedi in the making!
    Friday, October 31, 2008 5:27 PM