locked
Remote Media Access RRS feed

  • Question

  • Hello,

    I have a unique problem I think. I can see all my media when I remote access in via the web. However, after it semi loads the page I get a "REQUEST FAILED" error and the "there was a problem with the web site, please see your administrator" description. I tried some of the other suggestions here, TURN OFF STREAMING, TURN STREAMING ON and using WMC to ensure that the libraries are there. Still get it. WMC is completely fine btw! I can stream pics and music on the server and my other machine without a hitch. But webbing in, no go.

    I have changed over the ports to use 8009 (for HTTPS) and have my WNDR3700 configured correctly (so I think). Like I said, no problems with remote access, just won't actualy serve the media up for some reason.

    Any help is appreciated. One more question if I may. When the next beta comes out, is there a path forward? Or is it a total reinstall?

    Thanks again.

    Thursday, June 10, 2010 3:53 PM

Answers

  • Welp, duh...when you said server logs above I thought...Event Viewer. Sure enough (see below). It seems it was something I did. When changing to use port 8009 instead of 443 I changed the home IIS setting. I guess it doesn't like it! Now, I'm not certain, is this a Vail bug or just me not knowing what the heck I am doing! But I thougt that I read that others here have done the same thing?

    It looks like it thinks that there is still a 443 somewhere? On top of the 8009 I switched to. Any ideas


    Hi rdmsys:

    Here're two known blocking issues in your scenario, where basically people cannot use a different port for RWA other than 443.

    1) we don't support changing iis ports and bindings. In .Net 3.5.1 there's no easy way allowing more than one ports binding to ASP.NET webservice. If you want to change it by yourself you can, but again it's not supported and will cause other problems in the website. Note, WSS CERTIFICATE SITE is used in other places in the product, please don't touch that.

    2) There's a known bug in the website that if you map an external TCP port to internal 443 on your router, media webservices will fail either. We are looking into fixing this now, hopefully in the future people can get around here.

    Thanks.


    windows home server team
    Friday, June 11, 2010 4:34 PM

All replies

  • Does streaming work inside your LAN? I.e. when you open http://server, instead of http://server.homeserver.com? If not, try changing back to standard ports, then test again. If it still doesn't work, file a bug on Connect with server logs.

    As for migration from beta to beta, Microsoft hasn't told us, and I doubt that they will much before the next beta is released. Best practice is to plan on flattening your server regularly.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, June 10, 2010 3:58 PM
    Moderator
  • Ken, no it still doesn't work from inside either. You mean NOT using HTTPS, ie 80? Thing is I can't cause my ISP blocks 80 and 443, that's why I went with the HTTPS via 8009 BUT, I have not tried using say 8008 via STANDARD HTTP. Or do you mean, just forgoe that altogether and try regular port 80 from inside?

    Thanks for the reply!

    Thursday, June 10, 2010 4:26 PM
  • Try regular port 80 from inside your LAN; don't use the FQDN, either, just the server name as I suggested above.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, June 10, 2010 4:34 PM
    Moderator
  • Welp, duh...when you said server logs above I thought...Event Viewer. Sure enough (see below). It seems it was something I did. When changing to use port 8009 instead of 443 I changed the home IIS setting. I guess it doesn't like it! Now, I'm not certain, is this a Vail bug or just me not knowing what the heck I am doing! But I thougt that I read that others here have done the same thing?

    It looks like it thinks that there is still a 443 somewhere? On top of the 8009 I switched to. Any ideas?

     

    WebHost failed to process a request.
     Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/15509283
     Exception: System.ServiceModel.ServiceActivationException: The service '/Remote/Service/Media/RemoteMediaService.svc' cannot be activated due to an exception during compilation.  The exception message is: This collection already contains an address with scheme https.  There can be at most one address per scheme in this collection.
    Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme https.  There can be at most one address per scheme in this collection.
    Parameter name: item
       at System.ServiceModel.UriSchemeKeyedCollection.InsertItem(Int32 index, Uri item)
       at System.Collections.Generic.SynchronizedCollection`1.Add(T item)
       at System.ServiceModel.UriSchemeKeyedCollection..ctor(Uri[] addresses)
       at System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses)
       at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses)
       at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
       --- End of inner exception stack trace ---
       at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
     Process Name: w3wp
     Process ID: 4788

    Thursday, June 10, 2010 4:53 PM
  • Okay here's more...there *ARE* two entries in the DEFAULT SITE BINDING..there is a lower case https which says 8009, which I am assuming is the one I changed. However, there is now (and I don't believe there was before, could Vail have done this trying to config my router?) ANOTHER uppercase HTTPS which is pointing to port 443!

    Also, there is a WSS CERTIFICATE SITE which says that HTTPS is using port 5010? Not exactly sure what this is.

    Any ideas? I mean I can delete the HTTPS binding for the default site which says 443 but what about this other WSS site?

    Thanks again!

    Thursday, June 10, 2010 5:05 PM
  • Welp, duh...when you said server logs above I thought...Event Viewer. Sure enough (see below). It seems it was something I did. When changing to use port 8009 instead of 443 I changed the home IIS setting. I guess it doesn't like it! Now, I'm not certain, is this a Vail bug or just me not knowing what the heck I am doing! But I thougt that I read that others here have done the same thing?

    It looks like it thinks that there is still a 443 somewhere? On top of the 8009 I switched to. Any ideas


    Hi rdmsys:

    Here're two known blocking issues in your scenario, where basically people cannot use a different port for RWA other than 443.

    1) we don't support changing iis ports and bindings. In .Net 3.5.1 there's no easy way allowing more than one ports binding to ASP.NET webservice. If you want to change it by yourself you can, but again it's not supported and will cause other problems in the website. Note, WSS CERTIFICATE SITE is used in other places in the product, please don't touch that.

    2) There's a known bug in the website that if you map an external TCP port to internal 443 on your router, media webservices will fail either. We are looking into fixing this now, hopefully in the future people can get around here.

    Thanks.


    windows home server team
    Friday, June 11, 2010 4:34 PM
  • Thanks Feng,

    Thing is when I deleted the 443 binding, it worked. Seems fine now but understand your warnings. I will keep an eye on it till the next beta update.

     

    Friday, June 11, 2010 7:17 PM