locked
CRM 2011 installation fails when trying to install the CRM databases on named instance of non-local ms sqlserver 2008 R2 RRS feed

  • Question

  • Hello,

    I need to install the CRM database on a different ms sql server 2008 than the server where I install the Reporting Server and CRM itself.
    The instance I need to install on is named like this:
    SERV1234\D123
    This is exactly the name in server properties in MS SQL Server Management Studio.

    Because of this name I defined the tag in my config-file.xml as follows:
    <SqlServer>serv1234\D123</SqlServer>

    There is only one error in the log file and obviously it translates the contents of the tag SQLServer from the config-file somehow incorrectly when trying to connect to the server serv1234.
    I get the following error message:

    17:36:29| Error| Check SqlServerAgentValidator : Failure: SqlAgent$D123 (SqlAgent$D123) service is not running on the server serv1234.

    What can I do to remedy this so that the installation runs thru?

    Thank you.

    Andreas

    Wednesday, March 30, 2011 3:53 PM

Answers

All replies

  • If you can connect to SQL server from Sql Server Management Studio you should be able to restart sql agent from there.  It should show up under the server on the right towards the bottom of the server objects.  I think you just right click and press start.
    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Wednesday, March 30, 2011 4:11 PM
    Moderator
  • Hello,

    this problem is still not solved.

    For the installation of CRM 2011 the central IT has now granted sysadmin rights.
    I can now right click on the sql Server agent on the named instance of this MS SQL Server 2008 and open the properties. However the funny part is that the three options in the context menu:
    Start, Stop, Restart
    are still being greyed out, they are inactive.

    The installation procedure still claims:

    10:19:55|  Error| Check SqlServerAgentValidator : Failure: SqlAgent$D123 (SqlAgent$D123) service is not running on the server servername.

    I wonder now whether the naming is correct. Why is there a $ sign after SQLAgent and before the name of the named instance? Is that how it should be?

     

    Would someone know how I could get around this error?

    Thank you.

    Regards
    Andreas

    Thursday, April 7, 2011 8:46 AM
  • At this point I think this is really a SQL Server question.  You need to talk to your DBA's and System Administrators and let them know you need to have SQL Server Agent turned on for your server.
    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Thursday, April 7, 2011 1:28 PM
    Moderator
  • If the service start/stop etc. options are disabled, this will be because you don't have the local machine rights to manage services, which is probably the cause of the error. I suggest you ask for temporary Administrator rights on the SQL Server machine during the  CRM installation. It might be possible that more restrictive rights would work - the key is that you need access to manage services
    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Friday, April 8, 2011 8:02 AM
    Moderator
  • Hi, did you ever find a resolution to thi problem?  I'm getting the same error.

    Cheers

    Monday, February 20, 2012 4:02 PM
  • Hi Brett,

    I also got this error soo many times i tried with different solutions and it got worked.

    1. Make sure your SQL Machine is connected to domain? Check your Preffered DNS Server

    2. Change the identity of the services the user who is having Local Admin Privilages

    3. Check the time sync in servers.

    4. If nothing worked out restart the server.

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/

    • Proposed as answer by Khaja Mohiddin Tuesday, February 28, 2012 2:29 PM
    Monday, February 20, 2012 7:12 PM
  • Khaja, 

    I think your number 1 is probably the same issue and what I ran into last night.  I think the problem is related to the SQL server not being attached to the same domain as the CRM Server.  

    That's my guess after what I saw.  I still haven't gotten this to work for a non-domain SQL server.

    Jamie


    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!

    Monday, February 20, 2012 7:20 PM
    Moderator
  • Hi Jamie,

    True, i have through this issue soo many times and i found that solution..

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/



    Monday, February 20, 2012 7:30 PM
  • You can message me from my about.me profile (see my signature).  It goes to my main email.  If I reply to it, you will have my email address.

    If you know how to get around the requirement of the SQL server being on the same domain,  I would love for you to post that here.

    Thanks!


    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!

    Monday, February 20, 2012 7:37 PM
    Moderator
  • Hi ANdi,

    There is one more reason,

    if you set identity as a user to run sqlserver service then re-check the username in active directory that someone has changed the password for that user.

    You need to change the password in services identity also to make it start or else service may not start.

    Regards,


    Khaja Mohiddin http://www.dynamicsexchange.com/ http://about.me/KhajaMohiddin

    Wednesday, February 22, 2012 12:53 PM
  • Even I faced the same issue. I opened port 445 bi--directional between CRM server machine and SQL Server machine. That will most probably solve the issue.

    -Purbarag

     
    Tuesday, February 28, 2012 2:16 PM
  • Even I faced the same issue. I opened port 445 bi--directional between CRM server machine and SQL Server machine. That will most probably solve the issue.

    -Purbarag

     

    follow this link http://www.elblogdedynamicscrm.com/post/2011/03/30/Instalando-Microsoft-Dynamics-CRM-2011-Parte-I-VI-%E2%80%93Preparacion.aspx its in spanish so u may translate.

    Tuesday, February 28, 2012 2:31 PM