locked
Problem with the silverlight server RRS feed

  • Question

  • Hello, i'am having some isues, i can't get to work my application in the silverlight server.

    This is what i do:

    Get the pictures in Microsoft ICE, select de HD View format then export.
    I get 3 files: A carpet named tiles, test.html and test.xml (at this point i can see the application locally)
    Then i copy the two other files from the page HD View: Create... (manifest.xml and HDViewOnLoad.js)
    Then i zip all of them in test.zip
    After that i have the zip and go to the silverlight streaming page and create the application and upload the file (test.zip)
    However, when i go to the application properties, i dont have a "Launch Application Test Page" link and i get the Configure this Application: This application requires a manifest to function correctly. [Create].

    and when trying to see the iframe, the page respond that it canot find the web page. The code of the iframe that i use is this:

    <iframe style='width: 320px; height: 240px; margin: 0' frameborder='0'
    src='http://silverlight.services.live.com/invoke/100062/test/iframe.html?FileName=test.xml&Viewer=0'>
    </iframe>

    any tips on what i'am doing wrong? thanks
    Monday, May 18, 2009 10:12 PM

All replies

  • Two questions to start with:

    Does anything in this thread help?  http://social.microsoft.com/Forums/en-US/msrhdviewcontrol/thread/69353328-8a4d-48b8-b5ad-9acada15141d

    Does your zip file look like the ones on this page: http://research.microsoft.com/en-us/um/redmond/groups/ivm/hdview/hdcreate.htm ?  note in your case since you are using ICE, the xml file names and the tile folder name will be different, but they should be in the same places in the folder heirarchy - xml in the folder above tiles.
    -Matt
    Tuesday, May 19, 2009 5:07 AM
  • Hi matt...

    Yes i did read that thread, but it didn't help. My zip file looks a little diferent from the one in that page, since in that, the zip files have both files for HD View, and HD View SL...

    If i export in the HD View tileset format, the zip that i upload have the following files:
    test.zip
     *tiles (this is a folder)
     *test.html
     *test.xml
     *manifest.xml (downloaded from the HD View: Create page)
     *HDViewOnLoad.js (downloaded from the HD View: Create page)
    However when i upload the files, it seems that the silver light server dosen't recognize my manifest.xml, since i dont get the "Launch Application Test Page" described in the create pagen, and i get the mensage that this application need a manifest to function correctly and i have the option to create one in there.

    If i export in the Deep Zoom Tile Set Format, the zip that i upload have the folowing files:
    test.zip
     *test_files (this is a folder)
     *test.html
     *test.xml
     *manifest.xml (downloaded from the HD View: Create page)
     *HDViewOnLoad.js (downloaded from the HD View: Create page)
    And like in the other format, i get the same page when i upload the files to the server. That i need a manifest so the application can function correctly.

    I think that i'am doing all the stepts in the right way, but it doesn't work. =/
    Tuesday, May 19, 2009 2:49 PM
  • I found my error..., it was in the hierachy of the files, i had an extra folder in the zip.

    test.zip ----> test folder ----> then all the documents, thats why the server didn't recognize my manifest.xml
    Tuesday, May 19, 2009 10:14 PM