locked
SATA Installation Failure RRS feed

  • Question

  • I am trying to install WHS from a purchased DVD. I made it through the first portion up to the point of restart. Upon restart, I get blue screen and STOP msg of: 0x0000006B. PROCESS1_INITIALIZATION_FAILED. I think it has something to do with the HD I am using, or the SATA PCI adapter, and finding the appopriate driver.

    Here's my Server hardware config

    SOYO KT400 Dragon Ultra MOBO
    Athlon XP 2400 processor
    Seagate SATA 500 GB HD
    SATA PCI Adapter Card w/ RAID Functions
    1 GB Memory

    My motherboard didn't have a SATA connection so I purchased the SATA PCI adapter for $20. I put the drivers for the PCI SATA Adapter on a USB key so I could find it during installation, but that didn't seem to help. The driver I specified was for MS Server 2003, not XP.

    Now I seem to be stuck. It gives me an option to try to pull the driver off of a floppy drive, but I don't have one of those anymore.

    Should I wipe the first part of the MHS server installation from the drive and try to start over? I have tried everything it seems.  One note, I do have an old IDE HD running XP but it's only 40GB. Not sure if there is something I could try to do with that.
    Sunday, January 27, 2008 5:13 PM

All replies

  • Hi,

    Beginning at the end, no need to wipe and start over. WHS will format all attached disks when it is being installed.

    If you're using a USB drive, all the required drivers will need to be under a folder called   /drivers not the root of the USB drive.

    Also, don't try to set it up in any form of raid - unless you know just what you are doing - as it can lead to problems and is an unsupported scenario. You will need to install the required drivers twice, once at the initial 'server 2003' install, and then again later for the WHS install.

    Your IDE drive is neither use nor ornament, WHS requires a minimum of 80GB; plus, you are leaving yourself open to future problems because the 'spare' space on the D; partition of your system drive is used as the landing space for any files you may transfer to the server. Microsoft recommend that your largest available drive at the time of building, is used as your initial system disk.

     

    Colin 

     

    Sunday, January 27, 2008 6:13 PM
  • I made the change that you suggested on the USB drive. And at the time of my first post, I was past the point where WHS already formatted attached disks and went through an install process (took about 45 minutes). Upon reboot, that is where I am getting these blue screens. It boots from CDROM option first in the BIOS. (I don't have an option of DVD) and pops up a blue screen that says "Windows Setup" and presents too options, hit F6 to add additional SCSI or RAID drivers or F2 to automated system recovery. After that, it gives me a blue screen with the message I listed initially. The F6 option doesn't do anything because it is looking for a floppy disk on the A: When I unattached the SATA HD earlier just out of desperation, it goes through the re-install and allows me to search for drivers on the USB, but that's the only time. Obviously, that's not much help because the HD isn't connected. I haven't had this much fun since a Linux installation...
    Sunday, January 27, 2008 7:12 PM
  • Here are some more interesting notes:

    I just tried reinstalling again. I received the message indicating, "Hard drive capable of hosting WHS was not found. Would you like to load additional storage drivers?" I said yes.... It then allows me to search for drivers. I navigate to my USB where I have the drivers that came with my SATA PCI card. WHS only lets me search for INF files. There are many drivers that came with the SATA PCI Card. I have tried loading the drivers in a folder called PIDE and one called VIARaid for both 2003IA32 and WinXP. Gives me message saying that,

    "The provided driver cannot be used to complete setup: txtsetup.oem was not found. Please see the WHS Release documentation for more detail."

    I assume that the INF file is calling the txtsetup.oem file when installing and it can't find it, even though it too is on the USB drive. I noticed on the SATA PCI Card CDROM that there is an setup.exe file that I believe normally does all the installation. Anything else.... perhaps my MOBO CDROM has a driver that I should be loading instead?

    Thanks!
    Sunday, January 27, 2008 7:27 PM
  • Still no luck, so I think I am going to return the SATA PCI card and either try a different one, or perhaps just run IDE HD's.
    Tuesday, January 29, 2008 3:21 PM
  •  

    I tried to install WHS under similar circumtances with the same results.  I have an older Dell Dimension 4400 which I thought I would use as a test bed for a 120 trail of WHS.  My configuration is as follows:

     

    Dell Dimension 4400

    Intel Centrino 1.7 GHz processor

    2 Seagate SATA 500 GB HDs

    SATA PCI Adapter Card w/ Raid

    1.3 GB Memory

    1 DVD ROM drive

    1 CD/CDRW drive

     

    To begin with, I attempted to use the existing 40 GB IDE hard drive and one SATA 500 GB drive as the data storage drive but got the message that the IDE drive was too small.  Therefore, I removed the IDE drive and decided to use both SATA drives.  I figured 1TB should be enough to hold the OS and the data.  I originally wasn't going to us the raid functionality but would consider it once the OS was installed.

     

    As I went through the installation process, it couldn't see the drives and asked for the device drivers.  I inserted the driver CD that came with adapter card, found and used the WinXP INF file, and continued the installation process as normal.  After an hour of copying the installation files to the now recognized hard drive, the system rebooted and I got the blue screen of death.  I attempted the whole process a second time and got to the prompt to press F6 and add additional drivers but the function key didn't work.  I reread the installation instructions and there wasn't any mention of the fact that the F6 required either a floppy disk or a USB drive.  I gave up after 3 more attempts to install the server software with no success.

     

    Here are a couple of suggestions, or feature requests, for future installation packages:

     

    1.  Allow the use of the smaller drives for the installation of the OS which would give greater flexibility in the individual system configurations.  Headaches could have avoided if we had been allowed to install the OS on a smaller drive and then use the SATA drives purely for data storage.

     

    2.  If the installation asks for the drivers and then recognizes the SATA controller and cards, copy the drivers to the hard drive with the rest of the installation files so that the install process can proceed without asking for the drivers a second time and without incident after the reboot.  If the drivers aren't going to be copied to the hard drive with the installation files, then, at least let the user use the F6 to search for the drivers on the OEM CD.

     

    The result of my experience is that I dumped the WHS installation all together and installed Ubuntu Linux, which installed nicely with the SATA drives in RAID 1 hardware configuration and the whole OS only takes up less than 1GB of the hard drive.

     

    Steve

     

     

     

    Wednesday, February 20, 2008 5:27 AM
  • I have been trying to add a SATA card after the original installation and getting similar issues. From the sounds of the driver descriptions above, it could be the same controller from Pluscom, using a Via VT6421A chipset.

     

    I had a slight advantage in that I could put the drivers on using the setup.exe. There is a txtsetup.oem file on the disk and so I presume it could be used with a bit of trial and error as part of the initial install.

     

    The problem I have, and I don't know if it is a faulty card or driver, is that it works fine with one SATA disk on port 1. However, if I add a second, I get a number of errors. It won't format, the system runs very slowly (presumably lots of disk retries and controller resets), lots of errors in event log and the occasional BSOD.

     

    I have two SATA disks and both work fine on port 1, but fail on port 2. As the controller only cost £7 ($15), I am cutting my losses and swapping the card for a different make.

     

    The card has Windows 2003 drivers on the CD, but that doesn't guarantee it is going to work I guess.

     

    Wednesday, February 20, 2008 9:10 AM
  • Does the card work with one disk connected to port 2? Or does only port 1 work?
    Wednesday, February 20, 2008 12:43 PM
    Moderator
  • Hi Ken,

     

    It is only port 1 that works. I have tried port 2 with port 1 and port 2 by itself and had problems with both. Hence why I think it could be a fault with the card. There is also an external port. This gives the same results as port 2. The documentation is sketchy and so I don't know if the external port is a separate port or a reproduction of port 2.

     

     

    Wednesday, February 20, 2008 2:24 PM
  •  

    Someone correct me if I am wrong, but since WHS is based off of SBS2003 it needs SATA drives explicitly installed from a floppy drive. (By that I mean F6 to install additional storage drivers during the blue screen install portion of WHS setup)

     

    Unless your mobo supports USB as floppy emulation

    Wednesday, February 20, 2008 3:14 PM
  • I believe that the WHS installation is based on the new WinPE installer (as used with Vista) and this has USB support during installation. This is certainly the case for the WHS Client Restore Boot CD.

     

     

    Wednesday, February 20, 2008 3:28 PM
  • Now I think about it you are right, when I tried my usb drive I had the drivers in the root of the drive as opposed to in a drivers folder so thats probably why it didn't work (I read somewhere that if it's in root of the usb drive it won't work.... I thought it was this thread but I can't find it now). Floppy worked flawlessly for me though Smile

    Wednesday, February 20, 2008 4:39 PM
  • I ran into a similar problem with intergtared SATA on the system board, the install would get throught the first phase, format the drive, copy the files, then rebbot and when it tried to load, would give the blue screen.    went into the BIOS and changed the emulation of the SATA drives from SATA to IDE and then it worked fine.   Once WHS was completely installed,  I went back in and changed the emulation of the controller chip set back to SATA and its working good

    Thursday, February 21, 2008 12:01 AM
  • Tim,

     

    I tried the installation again and finally got it to work.  The driver CD, that came with my card, had the drivers under several subdirectories under the main root directory.  The txtsetup.oem had scripting that looked for one of these subdirectories labeled "I386".

     

    I copied the txtsetup.oem and the /i386 directory to the /drivers directory on a floppy and ran the WHS setup again.  I had to search for the driver on the initial wizard but after the reboot and pressing F6 to add additional drivers, the WHS setup saw the "server 2003" driver listing and correctly loaded the driver.  This is while running the SATA drives in hardware Raid 1 configuration.  WHS automatically recognizes that the drives are running in Raid 1 and insures that drives are syched up.

     

    To all who may be trying to install WHS with a SATA interface card and are receiving errors.  Just make sure that the drivers and their respective directories are copied correctly to a floppy or USB drive.  Open the txtsetup.oem in a text editor and verify that the path structure under the /drivers root directory matches what the txtsetup.oem file is looking for.  For me, mine looked like ..\i386\NT5\..., therefore, the floppy path would be A:\drivers\i386\NT5\.. as an example.

     

    I hope this is helpful,

    Steve

    Thursday, February 28, 2008 7:47 AM