locked
Remote Access Setup with Switch RRS feed

  • Question

  • I an using a D-Link 8-port switch. No router.  How do I set this up?
    73/oldsarge7056
    Thursday, May 13, 2010 1:45 PM

Answers

  • I an using a D-Link 8-port switch. No router.  How do I set this up?
    73/oldsarge7056
    You don't.  You need a router in your LAN in order for RA to work.
    Thursday, May 13, 2010 2:01 PM
    Moderator
  • If your broadband modem is capable of acting as a router, you should have little problem. Ask your ISP how to configure it, probably through a web interface of some sort. This really isn't a desirable configuration, though, as your broadband modem may not have much functionality beyond DHCP and all ports open.

    If it isn't capable of acting as a router, kariya21 has answered your question.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, May 13, 2010 3:01 PM
    Moderator

All replies

  • I an using a D-Link 8-port switch. No router.  How do I set this up?
    73/oldsarge7056
    You don't.  You need a router in your LAN in order for RA to work.
    Thursday, May 13, 2010 2:01 PM
    Moderator
  • Thanks,  I was afraid of that.  There was no problem in whs1.
    73/oldsarge7056
    Thursday, May 13, 2010 2:10 PM
  • If your broadband modem is capable of acting as a router, you should have little problem. Ask your ISP how to configure it, probably through a web interface of some sort. This really isn't a desirable configuration, though, as your broadband modem may not have much functionality beyond DHCP and all ports open.

    If it isn't capable of acting as a router, kariya21 has answered your question.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, May 13, 2010 3:01 PM
    Moderator
  • Thanks,  I was afraid of that.  There was no problem in whs1.
    73/oldsarge7056
    Well if it worked in v1, you must have a modem/router combo device, in which case you should be able to set up RA for Vail as well.  All you have to do is change the IP address of the port forwarding in your router menu (pointing ports 80 and 443 to the IP address of your Vail box; 4125 is no longer needed).
    Friday, May 14, 2010 2:28 AM
    Moderator
  • You are correct Kariya21.  I have a Westell modem which is also a router.

    I have set up forwarding and opened ports 80 & 443.  The Vail wizard shows that the remote connection is available.  I can ping the Vail server with its numerical and proper addresses, all ok.  It will also ping from the new domain address I set up.  However, when I attempt to connect from the remote icon it shows an error that the server is not accepting the call. 

    Evidently, I have done something wrong, but it's not apparent to me......one possible snag.  In my googling on the subject I noted that some people say the Westell doesn't support UPnP, but I can't confirm that.  Is this the no-no that I am encountering?  I would think that if I can ping the server, I can connect.....


    73/oldsarge7056
    Friday, May 14, 2010 4:46 PM
  • You are correct Kariya21.  I have a Westell modem which is also a router.

    I have set up forwarding and opened ports 80 & 443.  The Vail wizard shows that the remote connection is available.  I can ping the Vail server with its numerical and proper addresses, all ok.  It will also ping from the new domain address I set up.  However, when I attempt to connect from the remote icon it shows an error that the server is not accepting the call. 

    Evidently, I have done something wrong, but it's not apparent to me......one possible snag.  In my googling on the subject I noted that some people say the Westell doesn't support UPnP, but I can't confirm that.  Is this the no-no that I am encountering?  I would think that if I can ping the server, I can connect.....


    73/oldsarge7056

    Your modem/router device might not handle loopback (internal LAN) requests correctly.  If the Dashboard shows no errors with RA, you should try connecting from somewhere outside your LAN (and probably not from your place of employment either as some companies block outgoing traffic on various ports).  Try from a friend's house, a local coffee shop, etc.

    As for uPnP, I don't use it anyway (I disabled it on my router), and set up the port forwarding myself.  You might try doing the same thing if you have any name resolution-type errors in the Dashboard.

    Friday, May 14, 2010 4:59 PM
    Moderator
  • Getting there......it appears that the reason the server won't allow a connection is because of a bad security certificate.  It says it was issued to another computer.  I have not done anything with this a far as I know.  There must be a way to renew the certificate.  I will look for it......I by-passed the security warning and found an intermediate page with all the computers listed and other information.


    73/oldsarge7056
    Friday, May 14, 2010 5:44 PM
  • Getting there......it appears that the reason the server won't allow a connection is because of a bad security certificate.  It says it was issued to another computer.  I have not done anything with this a far as I know.  There must be a way to renew the certificate.  I will look for it......I by-passed the security warning and found an intermediate page with all the computers listed and other information.
    73/oldsarge7056
    Try running through the domain name set up again.
    Friday, May 14, 2010 6:40 PM
    Moderator
  • Yes, I did that....no joy.  It looks like the best option is a complete reinstall.   Thanks for your help.
    73/oldsarge7056
    Friday, May 14, 2010 6:53 PM
  • Yes, I did that....no joy.  It looks like the best option is a complete reinstall.   Thanks for your help.
    73/oldsarge7056
    If you didn't flatten your server yet, you should probably file a bug report on Connect.
    Friday, May 14, 2010 7:39 PM
    Moderator
  • Bad security certificate is a message which you get, if you try not to use the external name (i.e. http://website.homeserver.com), but the internal (i.e. http://server), since the certificate is issued for that external name. This should not block you from acessing your home server remotely with the short name, you have only to click the Connect to the website anyway link on the warning page.

    As others have said already, you may have to check from outside of your home network, if Remote Access is working properly.

    Best greetings from Germany
    Olaf

    Saturday, May 15, 2010 10:11 PM
    Moderator