locked
Problem with popup message in Dynamics 4.0 RRS feed

  • Question

  • Hello there,

    Our organization for CRM is not English so from time to time I have a hard time figuring what exactly error messages mean.

    I´m having one when I create a new quote detail(product) and the hit save. I´m going to try to translate into English to see if anyone has any idea what the problem is :

    "It is not possible to load the plug-in type".

    I am updating some plugins in a project solution and what I do is change the plugin, recompile and then put the dll in the assembly folder of the default installation path for CRM Dynamics. For ClientScripts I do the same and the put them in ISV folder at inetpub\wwwroot.

    Anyone has any idea what might be causing the message?

    Thanks in advance.

     

     

     

     

    Wednesday, September 7, 2011 4:27 PM

Answers

  • Try by registering (after unregister) it again after you have recompiled your assembly.
    • Marked as answer by Agenteusa Wednesday, September 7, 2011 6:01 PM
    Wednesday, September 7, 2011 4:56 PM

All replies

  • Try by registering (after unregister) it again after you have recompiled your assembly.
    • Marked as answer by Agenteusa Wednesday, September 7, 2011 6:01 PM
    Wednesday, September 7, 2011 4:56 PM
  • That solved it. What is strange wis I´ve been changing the plugins and updating them as explained above and that problem hadn´t arisen yet.

    You have any idea why it happened, or at least any tip for future reference?

    Marking as answer. Thank you.

     

     

    Wednesday, September 7, 2011 6:01 PM
  • Registering database and GAC would require reregistering.

    logically, if you are registering with the disk you may not need to reregister (not tested).

    Changing from disk to database and back to disk may cause to load a wrong  version (sometimes)

    Wednesday, September 7, 2011 6:57 PM
  • Strangely the problem is back after I had to update some more plugins. This time I can´t fix it even using the same steps I did yesterday :(

    My plugins were disk based from the beginning so I really can´t understand what is going on :S

    I have marked your reply as answer, but it seems I need more tips.  The error message is the same, the problem is exactly the same...

    Anyone can provide any further help, please?

     

    Thank you

     

     

     

    Thursday, September 8, 2011 4:49 PM
  • if you have tried reregistering , you may try reset IIS.

    Again make sure that you are copying the correct dll and you are registerign the same (some times your eyes will deceive you).

    as a last attempt - register in the database. database is always the better option.

     

    Thursday, September 8, 2011 5:14 PM
  •  

    I am restarting IIS and even the CRMAsyncService.

    The dll is correct (there is only one so no mistake there).

    Even though it worked yesterday I´m thinking something here. Yesterday when I unregistered the dll with Plugin Reg. Tool, my steps/instructions were also removed. When I registered the dll again they were missing. I had to export the dll from the production server (which is identical) and import in the dev server again to get those instructions back. That said it didn´t work today.

    Could this be the cause? How come the steps aren´t in my dll? Where are they stored?

    Again I´m sorry for all the questioning but I´m a bit new to CRM development.

    I appreciate the time lended to try and solve my issue.

     

    Thank you

     

     

     

     

    Thursday, September 8, 2011 5:33 PM
  • Once you unregister the DLL your steps would get deleted.

    re-registering process includes registering the assembly and the recreating the steps..

     

    Thursday, September 8, 2011 7:34 PM

  • Hmmm i see, so is there any way to somehow keep the steps intact when unregistering? Cause I have like 24 plugins with at least one step each :S
    Thursday, September 8, 2011 9:20 PM
  • you cannot keep the steps with unregister (as the steps are like children to your assembly).

    SDK has sample projects (look for plugindeveloper) you can customize to automatically register your plugin and steps without the registration tool.

     

    Friday, September 9, 2011 2:57 PM