locked
localhost is online but isn't responding to connection attempts RRS feed

  • General discussion

  • This is my Windows Home Server 2011 and I can no longer get my home webpage, or any page on my server, to display.  I actually have a main website then two "application" sites attached to it so the web site is www.mydomain.com and the two applications are at www.mydomain.com\site1 and www.mydomain.com\site2.  When I try to access them, I get the error message #404 site not found.  Everything I've tried gives me the same results.  I have tried directly from the servers desktop, from other computers in my local network and through the internet from my work.  The only other indication I've seen of a problem is that when I click on the "Fix connection problem" I get the message "website (localhost) is online but isn't responding to connection attempts." message.  These sites were working but now it seems like the system can't see the C:\inetpub\mydomain.com location.  I've even tried accessing them via the ip address with the same results.

    This is not somebody else's system, this is mine.  It was working before and I'm not sure what I've done to cause it to stop.  If I can figure out what's causing the problem, I know I can figure out what to do to fix it.  So far all my searching for troubleshooting help keeps pointing to the browser for fixes but I'm pretty sure I've eliminated that as a possibility with the different client locations, different versions, and access methods.  One last piece of info is if I try to TELNET using port 80 on the IP address from a local area networked computer, I just get the message that it can't open port 80.  That's been making me look in the direction of the firewall settings but I'm not sure what to look for in there.  Suggestions on what to try or how to test this server's web services?  TIA.


    RKWoodward

    Tuesday, July 1, 2014 3:00 AM

All replies

  • You tried https://www.mydomain.com? So how do you arrange this names resolution? Dyndns? Since a 3rd party domain hosted on your WHS is not part of the default feature set, it is hard to support.

    Or is it a default Windows Home Server domain? (https://xxx.homeserver.com)? Port forwarding in the router still hits the current internal IP address of your server? A ping to your domain name resolves to the current external IP address of your router?

    Best greetings from Germany
    Olaf

    Tuesday, July 1, 2014 1:01 PM
  • Thanks for your reply, Olaf.  I do use a DYNDNS type of service to resolve to my server but I'm pretty sure that I elimiate all DDNS issues by trying to open the website from the servers desktop using either "localhost" or "127.0.0.1" instead of my domain's web address.  On my router, I have a default DMZ set up to this server and if I switch it that over to a different computer in my LAN, I'm able to access the test web server running on that other computer.  I believe that proves it's not the pass-through of the router.

    Once again, from the server desktop that is running Windows WHS 2011, and the IIS service, if I try to access any webpage on that server, I get the 404 error that it cannot find the document.  Then when I click on the "Fix the problem" button, it comes back and tells me "localhost is online but isn't responding to connection attempts."  I could unplug the network cable and I should be able to bring up the webpage but cannot.  This site had been working before but I don't know what's changed.  An MS update, maybe, but I do not have any indication that is what happened.  Virus, maybe, but I don't get any report of one from the different methods I use to detect one.

    Thanks very much.


    RKWoodward

    Tuesday, July 1, 2014 2:48 PM
  • Did you apply an eventually unsupported .NET Framework update recently?

    These have been known for trouble in the past (WHS v1) and required some manual changes in the IIS console to revert back to the correct version.

    If you open the IIS console directly - is the file where it should be and can you browse it from there?

    Best greetings from Germany
    Olaf

    Tuesday, July 1, 2014 3:02 PM
  • From the Update History list, two .NET updates were applied, successfully, on 5/15/2014.  Everything I see on the two, KB2931356 and KB2931368, seems to be normal with no ill side effects.

    When I go to the IIS console, I click on the site name in the left column then in the right column, I click on "Browse www.mydomain.com on *:80 (http)" then after 30 seconds or so, I get the page "This page can't be displayed" with the button "Fix connection problem."  It's after clicking this button that I get the troubleshooter that tells me "...it's online but isn't responding...".


    RKWoodward

    Thursday, July 3, 2014 4:26 AM
  • Some websites require specific versions of .NET associated. Some .NET updates changed these associations in IIS in the past causing trouble loading the old WHS websites. Page cannot be displayed can also have to do with authentication issues.

    Since I have no clue about your website, it is hard to troubleshoot. (Website issues with IIS are hard to troubleshoot also for WHS built in websites.)

    Is the normal Windows Home Server site (https://servername; http://servername/connect) still available?

    And - did you ever, since this happened, reboot the server and the router?

    Best greetings from Germany
    Olaf

    Thursday, July 3, 2014 8:17 AM
  • I was able to successfully use https://computername from the servers desktop.  That was pointing to a different (old) web application.  I then went to another computer in my LAN and from there, I get the message "There is a problem with this website's security certificate" and given the option to ignore and go to the site anyway.  That also works.  (I'll worry about the security certificate issue after I get this problem fixed.)

    I can not, however, get to http://computername.  Thinking it might be something in the homepage directory, I stopped that webpage, renamed the current directory to a hold name, then copied the old web app to the name of the homepage directory.  I then restarted the website and I'm still unable to get any response other than the 404 document not found indication.  It's like something is messing up the port 80 connections or something along those lines.

    Once, again, I'd like to thank you for trying to help me out.


    RKWoodward

    Friday, July 4, 2014 12:53 AM
  • Since WHS 2011 is using only https, you are on your own with your custom site.

    You could check the bindings in IIS.

    Related to the security certificate this is a normal behavior, since this normally is created for your site.domain.com address and not for the short name.

    So calling https will always trigger this kind of warning.

    Best greetings from Germany
    Olaf

    Friday, July 4, 2014 8:16 AM
  • Okay.  Thanks for your time.

    Can anybody else tell me why my system is no longer responding to http connections?


    RKWoodward

    Friday, July 4, 2014 2:59 PM