Windows-based script host not working using windows 7 RRS feed

  • Question

  • I keep getting sent to one forum to another. I talked to microsoft and they said go to another forum. HELP!!!

    I been to about every forum there is and still have not gotten an answer on how to fix my problem. I run windows 7 professional and use notepad++ to write scripts. I cant' open them after saving them. I can't find the windows based script host anywhere. How do I add this or fix why it doesn't work.

    Friday, February 10, 2012 2:03 PM


  • I don't see where you have posted any questions. Do you have more than one identity?

    Questions regarding scripting and windows script host should be posted in "The Scripting Guy's" forum:


    However, more  detail about your problem might be needed.

    The first point is that WSH (Windows Script Host) comes builtin with every Microsoft operating system since Windows 2000. It should be available and there there is no need to find it, unless it has become corrupt. There are two host applications that are used to run scripts (such as VBScript), cscript.exe and wscript.exe. The cscript program runs scripts in a command line environment. Wscript.exe runs them in a GUI environment. There are several  ways to run a VBScript (saved in a file with *.vbs extension). One is to double click the *.vbs file (perhaps in Windows Explorer), in which the default host program (usually wscript.exe) runs the script. Another method is to run the script at a command prompt. Then you can run the host program you prefer and pass the *.vbs file as a parameter.

    I'm not familiar with notepad++, but I use notepad to write scripts. I've never seen where a file can be saved, but not opened. Do you mean you cannot run the script? Do you mean the file does not automatically open in notepad++ when you double click it?

    In any case, you are in the wrong forum. Please post your question in the Scripting forum I suggested.

    Richard Mueller - MVP Directory Services

    Friday, February 10, 2012 6:36 PM