CRM 2011 Team Security Issue RRS feed


All replies

  • I was able to recreate this on my end.  I would maybe try an IIS reset or something after the assignment to see if it resolves anything.  This does seem to be a bug though as it is not the intended behavior.  I haven't installed the newest rollup in my environment by I don't see anything that suggests that this is resolved in rollup 3.



    Jamie Miley
    Check out my about.me profile!
    Linked-In Profile
    Follow Me on Twitter!
    • Proposed as answer by Jamie MileyModerator Tuesday, September 6, 2011 4:56 PM
    • Marked as answer by mcnarya Friday, September 9, 2011 1:19 PM
    Tuesday, September 6, 2011 4:56 PM
  • I did a quick test with my build with rollup 3 installed and was unable to duplicate the problem.  It appears to be fixed with rollup 3.

    Jon Capps

    • Marked as answer by mcnarya Friday, September 9, 2011 1:19 PM
    Tuesday, September 6, 2011 6:16 PM
  • I am going to have rollup 3 installed, and try again.
    Tuesday, September 6, 2011 6:53 PM
  • Rollup 3 seemed to have fixed the issue as long as the user has 1 security role assigned to them.  With zero security roles the issue still occurs.  The one security role I do have assigned to the user has basically zero permissions.
    Friday, September 9, 2011 1:19 PM
  • I don’t think UR3 completely fixed this.

    Here is my scenario:

    * User A w/ no individual security role
    * Team A has a role with the below basic privileges
    + User Entity UI Settings
    + User EntityInstanceData
    + User read to Contact

    * User A added to Team A

    User A is able to login to CRM w/out a security role attached to them, but CANNOT create a new Contact form

    * Assign the same role to User A

    User can now see the form

    * Remove the role from User A

    User can still see the form.

    So it seems with the initial User Entity UI Settings and User EntityInstanceData already setup, it’s stored in the system and not removed when the role is removed.

    Thursday, August 16, 2012 6:08 AM