locked
ASP.NET 2.0.50727.0 Web Event - 1310| "A Configuration Error Has Occurred" RRS feed

  • Question

  • Hi all, I am receiving the below error message each time my Communicator client attempts to download the ABS files.  Read through some other posts and tried enabling "Directory Browsing" for the /ABS folder, but that didn't help, although I was able to browse to the site via IE and see the listed files.  I checked in the /abs web.config and saw a couple of entries, however the below error seems to suggest this web.config isn't right.  Can anyone tell me if the ABS web.config is accurate?

     

    <configuration>
      <system.web>
        <httpHandlers>
          <add verb="*" path="*.lsabs" type="Microsoft.Rtc.ABServer.AbsHttpHandler, abserverhttphandler"/>
          <add verb="*" path="*.dabs" type="Microsoft.Rtc.ABServer.AbsHttpHandler, abserverhttphandler"/>
        </httpHandlers>
      </system.web>
    </configuration>

     

    BTW:  I am sharing my Default Website with the following other

    • SharePoint 2007
    • Exchange 2003
    • Windows Certificate Services

    Error Being Displayed in Application Log

    ===============================

    Event code: 3008

    Event message: A configuration error has occurred.

    Event time: 7/28/2007 12:45:52 AM

    Event time (UTC): 7/28/2007 7:45:52 AM

    Event ID: 98e5d244ec494e589b01165b961c0660

    Event sequence: 3

    Event occurrence: 1

    Event detail code: 0

    Application information:

    Application domain: /LM/W3SVC/1/Root/Abs/Int-8-128300823514531250

    Trust level: WSS_Medium

    Application Virtual Path: /Abs/Int

    Application Path: C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Address Book Files\Int\

    Machine name: RYSHOSTER

    Process information:

    Process ID: 3120

    Process name: w3wp.exe

    Account name: RYSHOUSE\RTCComponentService

    Exception information:

    Exception type: ConfigurationErrorsException

    Exception message: Could not load file or assembly 'ABServerHttpHandler, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. Failed to grant minimum permission requests. (Exception from HRESULT: 0x80131417) (C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Address Book Files\Int\web.config line 4)

    Request information:

    Request URL: https://ryshoster.ryshouse.com/Abs/Int/F-095f.lsabs

    Request path: /Abs/Int/F-095f.lsabs

    User host address: 192.168.1.105

    User: RYSHOUSE\Administrator

    Is authenticated: True

    Authentication Type: Negotiate

    Thread account name: RYSHOUSE\RTCComponentService

    Thread information:

    Thread ID: 5

    Thread account name: RYSHOUSE\RTCComponentService

    Is impersonating: True

    Stack trace: at System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase)

    at System.Web.Configuration.HttpHandlerAction.InitValidateInternal()

    at System.Web.Configuration.HttpHandlersSection.ValidateHandlers()

    at System.Web.Configuration.HttpHandlersSection.FindMapping(String verb, VirtualPath path)

    at System.Web.HttpApplication.GetHandlerMapping(HttpContext context, String requestType, VirtualPath path)

    at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig)

    at System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Custom event details:

    For more information, see Help and Support Center at

    Saturday, July 28, 2007 8:10 AM

All replies

  • I get the same error.

     

    So, my 2007 Communicators cannot access the address book and they get 
    prompted for credentials to access it on sign in.  Any ideas?
    
    Windows 2003 Enterprise Server R2 SP2 x64
    OCS 2007 RTM
    Communicator 2007 on Vista Clients, x86 and x64.
    
    When this is fixed, then I've got issues with the Web Access Server.  Thanks.
    
    here's the asp error getting kicked out in the even log:
    
    Event code: 3008 
    Event message: A configuration error has occurred. 
    Event time: 8/27/2007 11:43:58 AM 
    Event time (UTC): 8/27/2007 4:43:58 PM 
    Event ID: b0bba664c5384cd7acc5d7b6437a0104 
    Event sequence: 79 
    Event occurrence: 26 
    Event detail code: 0 
     
    Application information: 
        Application domain: /LM/W3SVC/1/Root/Abs/Int/Handler-1-128326473356994644 
        Trust level: Full 
        Application Virtual Path: /Abs/Int/Handler 
        Application Path: C:\Program Files (x86)\Microsoft Office Communications 
    Server 2007\Web Components\Address Book Files\Int\Handler\ 
        Machine name: PHOENIX 
     
    Process information: 
        Process ID: 664 
        Process name: w3wp.exe 
        Account name: NT AUTHORITY\SYSTEM 
     
    Exception information: 
        Exception type: ConfigurationErrorsException 
        Exception message: Could not load file or assembly 'abserverhttphandler' 
    or one of its dependencies. An attempt was made to load a program with an 
    incorrect format. (C:\Program Files (x86)\Microsoft Office Communications 
    Server 2007\Web Components\Address Book Files\Int\Handler\web.config line 8) 
     
    Request information: 
        Request URL: https://pool01.scheh.com/Abs/Int/Handler/F-097d.lsabs 
        Request path: /Abs/Int/Handler/F-097d.lsabs 
        User host address: 192.168.6.67 
        User: SCHEH\Troy W. Scheh 
        Is authenticated: True 
        Authentication Type: Negotiate 
        Thread account name: NT AUTHORITY\SYSTEM 
     
    Thread information: 
        Thread ID: 7 
        Thread account name: NT AUTHORITY\SYSTEM 
        Is impersonating: False 
        Stack trace:    at System.Web.Configuration.ConfigUtil.GetType(String 
    typeName, String propertyName, ConfigurationElement configElement, XmlNode 
    node, Boolean checkAptcaBit, Boolean ignoreCase)
       at System.Web.Configuration.HttpHandlerAction.InitValidateInternal()
       at System.Web.Configuration.HttpHandlersSection.ValidateHandlers()
       at System.Web.Configuration.HttpHandlersSection.FindMapping(String verb, 
    VirtualPath path)
       at System.Web.HttpApplication.GetHandlerMapping(HttpContext context, 
    String requestType, VirtualPath path)
       at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String 
    requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig)
       at 
    System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& 
    completedSynchronously)

     

    Monday, August 27, 2007 10:59 PM
  •  

    We've been spending alot of time on this one...I suspect you're running OCS on a 64bit server using 64bit ASP...likely because you want to co-locate with Exchange 2007.  We've been running Exchange and LCS for quite some time but OCS's ABS has a dependancy in WMI that is locked to 32bit.  We've raised this as a bug with Microsoft with no reponse yet.  Everything else works except ABS in the config.

     

    -trevor

    Saturday, October 6, 2007 1:01 AM
  •  

    Any news on this?  Or does anybody have a work-around?  I'm thinking about making a second site and putting 'ABS' on it, because i think you can specify which ASP version to use based on sites, which may fix it... I'm not sure.  I've done tons of digging and this is the only reasonable explanation.
    Tuesday, October 23, 2007 4:39 PM
  •  

    I've just decided to throw OCS onto a new vm 32 bit server, cleared up everything.  This should really be addressed

    Thanks !

    Wednesday, October 24, 2007 10:59 PM
  • Guys, I am getting this exact same error on a 32bit machine. I can not figure out why. Any ideas?? I am also running sharepoint. I first noticed an issue where the lsGroupExpAppPool would fail (500) with forefront security for sharepoint installed. So I removed that service and now again, stuck with the same error as above.

     

     

    Thursday, January 3, 2008 3:56 PM
  • Have you tried reregistering asp.net? 

     

    Back to the original post, you cannot run both versions of .NET. simultanously.  Exchange 2007 runs on the 64 bit version whereas OCS007 runs on the 32 bit version.  The install goes through which is very misleading but IIS component will not work in the end.  So it's your choice, one or the other.  Check out David Wang's blog. 

     

    http://blogs.msdn.com/david.wang/archive/2005/10/06/HOWTO_Diagnose_one_cause_of_503_Service_Unavailable_on_IIS6_on_64bit_Windows.aspx

     

    Friday, January 18, 2008 6:19 AM
  • Hi Brett9877,

     

    I also came acrss the same problem when I try to configure the Sharepoint site with a custon authentication provider

    I able to executed this Custom Provider in dev environment but when I moved it to Test environemtn I am facig this problem?

     

    how did u over come this problem?

    Thanks in Advance

    Wednesday, March 26, 2008 7:08 PM
  •  

    If you are running sharepoint and OCS on the same server my blog might help you...

     

     

    http://brett-iw.spaces.live.com/blog/cns!2B9BA18F46ED95C5!140.entry

     

    However if this is not related to ABS errors our problems are very different.

    Wednesday, March 26, 2008 7:20 PM
  •  

    hello.

     

    I'm running into a similar issue a server running sharepoint services 3.0. This all stared after i created a test site in the INETPUB folder now none of sharepoint sites are working. I'm not runing ABS.

     

    Thanks in advance for any feed back.

    app log has the following error: 


    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1310
    Date:  6/12/2008
    Time:  1:15:33 PM
    User:  N/A
    Computer: AVALANCHE
    Description:
    Event code: 3006
    Event message: A parser error has occurred.
    Event time: 6/12/2008 1:15:33 PM
    Event time (UTC): 6/12/2008 5:15:33 PM
    Event ID: 59cead7dd8b84a01a2ae782aa3bac402
    Event sequence: 1
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1357199652/Root-1-128577645334414008
        Trust level: wss_custom
        Application Virtual Path: /
        Application Path: N:\INETPUB2\wwwroot\wss\VirtualDirectories\80\
        Machine name: AVALANCHE
     
    Process information:
        Process ID: 3260
        Process name: w3wp.exe
        Account name: domain\user 
     
    Exception information:
        Exception type: HttpException
        Exception message: Data at the root level is invalid. Line 1, position 1.
     
    Request information:
        Request URL: http://localhost/
        Request path: /
        User host address: 127.0.0.1
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: domain\user 
    Thread information:
        Thread ID: 1
        Thread account name:  domain\user 
        Is impersonating: False
        Stack trace:    at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
       at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
     

     

     

     

    Thursday, June 12, 2008 5:52 PM
  • Did you find a solution?  I am getting the same error after I used Sharepoint Designer to "convert to web" a website folder inside the inetpub folder.  I noticed the error immediately because our sharepoint sites would not load any more so I used designer again to "convert to folder" the new website.  The new website is nothing to do with sharepoint, just hosted on the same IIS, and it still works fine, as do the other websites, it is just sharepoint that has stopped working.

     

    Here is the error:

     

    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1310
    Date:  24/06/2008
    Time:  9:50:06 a.m.
    User:  N/A
    Computer: GLDC
    Description:
    Event code: 3006
    Event message: A parser error has occurred.
    Event time: 24/06/2008 9:50:06 a.m.
    Event time (UTC): 23/06/2008 9:50:06 p.m.
    Event ID: a7dc8072d4a94155b13d24c49e0ea672
    Event sequence: 1
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/173409492/Root-3-128587314065468750
        Trust level: WSS_Minimal
        Application Virtual Path: /
        Application Path: C:\Inetpub\wwwroot\wss\VirtualDirectories\17692\
        Machine name: GLDC
     
    Process information:
        Process ID: 9632
        Process name: w3wp.exe
        Account name: domain\user 
     
    Exception information:
        Exception type: HttpException
        Exception message: Data at the root level is invalid. Line 1, position 1.
     
    Request information:
        Request URL: http://gldc:43686/_vti_bin/sitedata.asmx
        Request path: /_vti_bin/sitedata.asmx
        User host address: 192.168.0.3
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: domain\user 
     
    Thread information:
        Thread ID: 5
        Thread account name: domain\user 
        Is impersonating: False
        Stack trace:    at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
       at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
     
     
    Custom event details:

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Monday, June 23, 2008 10:03 PM
  • Just an FYI.  OCS with any other application, exchange sharepoint, etc, is not a supported configuration.  You won't get much help from Microsoft on this.  If you are running a 64 bit system you need to register .lsabs and .dabs on the website so that it uses the aspi_something dll in the asp.net 2.0 sp1 install directory.  I can't remember what the exact name of the dll is since I am not at work on my computer.  Also check to make sure you have the righ certificate assigned to your IIS website.

     

    Tuesday, June 24, 2008 3:43 AM
  • Just an FYI.  Here are the steps.  This assumes that you can get to the DLX website but cannot download the address book.

     

    1. In the IIS manager Expand: Default web site\Abs\Ext
    2. Right click on Handler, select properties
    3. On the Virtual Directory tab, hit the Configuration button.

    4. Check for presence of .lsabs and .dabs extensions.
    If not found, hit Add and fill in the following:

    5. Executable: c:\windows\microsoft.net\framework\v2.0.50727\aspnet_isapi.dll
    6. Extensions: .dabs
    7. Verbs, Limit to GET
    8. Script engine, checked.
    9. Verify that file exists, unchecked.

    10. Repeat steps 4-9 for but add .lsabs files in step 6.
    11. Repeat steps 1-10 for but use Default web site\Abs\Int in step 1.

    Tuesday, June 24, 2008 12:34 PM