locked
Incorrect CRM Url Error - while accessing Ribbon Workbench 2011 RRS feed

  • Question

  • Dear all,

    I am using CRM 2011 On-premise. I have installed Ribbon Workbench 2011 solution onto my CRM and when I try to open it.I am getting below error message saying Invalid CRM Url could anyone please help me on this.

    Many thanks for your time in advance...


    Tuesday, January 14, 2014 12:05 PM

Answers

  • Hi,

    I replied to your support email as well. The url is a fall back test one that is used if the Ribbon Workbench is running outside of the Dynamics CRM context. It looks as though you have some server issues that result in the domain that you are accessing CRM through being different to the one that CRM thinks it should be. This would result in cross domain script issues.

    I suggest you look at your server configuration.

    Hope this helps,

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Friday, January 17, 2014 8:00 AM
    Answerer

All replies

  • What URL are you browsing to to access CRM? It looks like your CRM server has multiple DNS entries or bindings or you are browsing to it by IP.

    Based on the error message in your screenshot, the Ribbon Workbench must only support browsing to CRM using the exact URL configured in the deployment settings - http://dev01:5555/RibbonWorkbenchDemo in your case. If you are using this URL then follow the instructions to contact the vendor of that product and log a support request with them.

    Wednesday, January 15, 2014 12:06 AM
  • Many Thanks for replying.Yes, we got multiple DNS entries. As you stated above http://dev01:5555/RibbonWorkbenchDemo  is not my URL, My CRM URL looks like - http://HostName/OrganisationName/main.aspx. Even I tried browsing CRM from server but still getting same error when opened the Ribbon tool. Anything that I can try for this issue.

    Thanks for your time.


    Wednesday, January 15, 2014 11:53 AM
  • Hi,

    I replied to your support email as well. The url is a fall back test one that is used if the Ribbon Workbench is running outside of the Dynamics CRM context. It looks as though you have some server issues that result in the domain that you are accessing CRM through being different to the one that CRM thinks it should be. This would result in cross domain script issues.

    I suggest you look at your server configuration.

    Hope this helps,

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Friday, January 17, 2014 8:00 AM
    Answerer
  • Ok.Many thanks to all for your time.

    Friday, January 17, 2014 10:26 AM