locked
Rebooted Vail box, now media library AWOL?? RRS feed

  • Question

  • I've been digging the new web ( silverlight ) based media streaming features of Vail.  I was accessing my media from my office yesterday; the videos were streaming fine, but I started getting an error when I tried to access the music library.  This morning I decided to reboot the Vail box to see if the music library would come back.  Unfortunately now when I load the web interface I just get "An error has occurred on the server..." in the media library box.  Is there someone out there that can rescue me from a day at the office with nothing to watch or listen to?  Many thanks.  TT

    UPDATE 1:  I bounced the server and I got the media library to load again, however the media indexer seems to have died.  The web interface is only showing 8000 of my music tracks.  That about 2/3rds of what I have on the server.  Also some of the videos on the server are not showing up as well.  I tried manually restarting IIS, but that didn't change anything.  If someone could point me to the process/program/service that does the media indexing so I can try to re-start that I would be eternally grateful.

    It wouldn't be a beta without some bumps in the road. :-)

    Wednesday, May 12, 2010 12:38 PM

All replies

  • I ran into similar problems, but restarting the Windows Media Player Network Sharing Service seems to remedy the situation, at least for a while until it breaks again. I couldn't find any information in any of the Event Logs to indicate what might be causing the service to break. Sometimes the media counts are accurate and other times they are way off. It seems as if the media library is lost and rebuilt from time to time. I thought it might be due to the large amount of Music (~280 GB) I added to the server, but that seems to not be the case.

    Aside from the obvious and expected hiccups, I am really enjoying the new streaming interface - it blows away TwonkyMedia capabilities.

    If anyone has any more useful information it would be much appreciated.

     

    Edit: I just thought I would add some more details as the problem continues for me quite frequently. I have to restart either the Windows Media Player Network Sharing Service, IIS or both to get the library to report accurately. Does the Media Library function as such, that is to say does it get built once and then simple display its contents? From my experience it seems as if the library keeps getting rebuilt - updating cover art to the client is always slow, searching music is slow and updating the "Library Details" is very slow. I have not tried accessing the content with a DLNA enabled device to see if this is any better, but once I do I will report my findings.

    Wednesday, May 12, 2010 1:53 PM
  • Thanks B, I'll give that a shot. P.S. Your music collection puts mine to shame. :-)
    Wednesday, May 12, 2010 2:01 PM
  • I am having the same problem, I have noticed if i keep refreshing the page eventually it will come up and work as expected.

    I wish there was a way to stream "recorded tv", I don't want to have to convert all the files, put them in the vid folder, and so forth

    Thursday, May 20, 2010 9:50 PM
  • Hi Brendan;

    Thanks for raising the issue, we do have known issue around the media library indexing, and we are actively work on it. You information is very helpful here. There are couple of seperate issues with NSS(Network Sharing Service) and our website logic, both of them are contributing to the symptom you've seen.

    In most of the cases I've seen, if your media collection shows exactly thousands of items on website, restart IIS only will cure (don't restart NSS and IIS together). Otherwise, you probably need to restart NSS or give the box some time to spin...

    Anyway, if you see explicitly there's an error reported on webpage say "blah blah contact your admin", please submit a bug with server cab.

    Thanks.

    -Feng


    windows home server team
    Thursday, May 20, 2010 11:49 PM
  • I believe I am having a similar issue with my vail server. Not all of my videos (maybe 2/3 are missing) are appearing in my library, and maybe 1/2 to 2/3 of those that do are listed at 0 minutes and will not stream remotely. I am away from the server at the moment, so I'll try the above steps and see if that resolves the issue.

     

    Joshua

    Monday, August 2, 2010 12:26 PM
  • I am having the same issue with my vail server. I have over 400GB of music and I am unable to stream music at work. I thought it was my verizon fios service because I was getting a low throughput. I had that issue resolved and I am still getting an error when the media library tries to load. It will occasionally diplay the library but when I try to explorer the music it errors out.

     

    Mike

    Wednesday, April 13, 2011 4:15 PM