none
SyncToy 2.1 Can't Find NAS Folder When Run From Task Scheduler

    Question

  • I'm using SyncToy 2.1 to keep two WIN7 computers and a Synology DS414j NAS drive in sync. I have several folder pairs configured, some between the two PC's and three between one PC and the NAS drive. I have a task set up for automatic syncing. The problem is SyncToy can't find the destination folders on the NAS drive if it's run from Task Scheduler. If I run SyncToy manually, everything works fine. I've even tried opening the command prompt and running the exact same program Task Scheduler is running (SyncToyCmd.exe -R), and it works perfectly. But when Task Scheduler runs the task, it fails to find the NAS folders with the following error message:

    SYNC: 08/21/2014 14:12:26:140: *** Failed to execute folder pair Downloads to NAS. Could not locate folder \\DISKSTATION\Downloads\.

    I've been looking for days for a solution and have not found anyone with this problem. Any ideas?

    Thursday, August 21, 2014 9:35 PM

All replies

  • I had similar issue - Win7, copying from NAS to local drive and working fine in GUI but not from Task Scheduler.

    The resolution for me was to change the path of the NAS drive from the Mapped Network Drive that I had setup (X:\Photos) and use the network path (\\NAS\Photos).  Strange issue really.

    Monday, November 17, 2014 1:47 PM
  • You know that's funny because I had it set up with the network path originally and it wouldn't find it. I read somewhere that making it a mapped drive would solve the problem but no go. I have since attributed it to a Windows bug and have given up and acquired a third party scheduling app and now everything works fine.
    Friday, November 28, 2014 5:18 PM
  • Hi,

    I have the same problem. I use a Ubuntu server as my NAS. This server crashed, so I bulid a new one with the same settings as the old one.

    I have used Synctoy for a long long time without any problems until I started the new server. Now Synctoy give me the same error as Reddogmatic; Could not locate folder \\NAS\Photos

    But everything works ok when running GUI. I have not done anything in my settings on my Win7 computer, and the settings are exactly the same on my new server. This is driving me crazy, as long as the settings are the same as before, this should work! I have deleted all old .dat files.

    What is the difference between GUI and Task Scheduler?

    Monday, December 29, 2014 9:39 PM
  • Hi Texxxas,

    Apparently the problem is not with SyncToy, it is with Task Scheduler. If you have had Task Scheduler work for you in the past, then I don't have an answer for that. I have never been able to get Task Scheduler to work correctly with SyncToy and a NAS drive. I have found that for some reason it works with USB external HDD's but will not work with a network connected hard drive. The same bug exists in Win8.1 as well. However, I have since found a third party task scheduler that works perfectly with SyncToy and my NAS drive. It is called System Scheduler by Splinterware. The free version only works when you are logged in but they have a paid version that runs as a service and will execute without being logged in. This has solved my problem.

    Thursday, January 01, 2015 6:22 PM