locked
SSRS Error Installing Dynamics CRM 4.0 RRS feed

  • Question

  • Hello, 
    
    I receive the following error when i attempt to install Dynamics CRM 4.0 on 
    our server:
    A server certificate could not be validated for URL: 
    https://PROPC-SERVER/ReportServer. 
    I can access the Report Server Page with HTTP or HTTPS quite fine, and SSRS 
    is set to not even require HTTPS. However, when i use HTTP in the address, it 
    says it needs an SSL connection. When i use HTTPS, that occurs. 
    
    For further information, i'm installing CRM 4.0 on a Server 2008 machine 
    also running SQL 2008, Exchange 2007, and a few other unrelated things. 
    Everthing is running on the same server. 
    We had CRM up and running before, but some issues caused us to have to 
    uninstall it, as well as several other server functions, and re-install them. 
    
    Anyone have any thoughts or ideas that may help me out? 
    
    Many Thanks,
    
    Gregg L.
    Friday, June 5, 2009 4:01 PM

Answers

  • Another possibility would be to find the RSReportServer.config file in the ReportServer directory and set SecureConnectionLevel Value=”0” - this would ensure that SSRS isn't trying to use an SSL connection.
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    • Marked as answer by Gregg L. _ Monday, June 8, 2009 4:52 PM
    Sunday, June 7, 2009 2:57 AM
    Moderator

All replies

  • It sounds like somewhere in your environment you have some setting incorrectly configured to look for a certificate.  We could only guess where that is happening and most likely wouldn't be able to identify it without looking around in your environment to troubleshoot.

    Basically, you should not need to use https to identify your Report Server during the installation process.  You will need to identify what is going on in your environment to correct this issue in order to move forward.


    Best Regards, Donna
    Saturday, June 6, 2009 4:03 PM
  • Another possibility would be to find the RSReportServer.config file in the ReportServer directory and set SecureConnectionLevel Value=”0” - this would ensure that SSRS isn't trying to use an SSL connection.
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    • Marked as answer by Gregg L. _ Monday, June 8, 2009 4:52 PM
    Sunday, June 7, 2009 2:57 AM
    Moderator
  • Donna and Scott,

    Thanks! That looks like it took care of the issue. The SecureConnectionLevel Value was set to 2, despite the setting in the configuration manager to not require HTTPS.
    I set it to 0, and the EDW was clear. I'm installing CRM now... I'll report back shortly with reults.

    Thanks again,

    - Gregg L.
    Monday, June 8, 2009 4:57 PM
  • It appears that there is another error... I'm unfamiliar with the general process on the new forums, since the original error was fixed, should i post a new thread for this error, or is it OK to pst it in a reply on this one?

    Thanks,

    - Gregg L.

    Monday, June 8, 2009 5:13 PM
  • Hi Gregg,

    There is no official protocol but it would probably be good to use a new post since this issue is cleared.
    Best Regards, Donna
    Monday, June 8, 2009 5:51 PM