none
Installation issue RRS feed

  • Question

  • I have been using Microsoft Money Business sunset edition for some time on my windows 10 system. However, had a issue awhile after 12/16/17 where it would ne longer open. Tried uninstalling the program and reinstalling but now sunset won't install. I keep getting the message "setup was unable to install some of the components needed to run Money. Try installing Money again." have tried modifying the registry for IE6 issue but didn't help. Event log seems to indicate it is looking for ATL80.dll file. Several in the registry but maybe not the right one? Any suggestions?? All my data for taxes from last year is in these files.
    Monday, January 29, 2018 6:20 PM

All replies

  • You posted this same issue back on January 4th:

    https://social.microsoft.com/Forums/en-US/7e7e8fc5-6235-4efa-a122-937f7d79831b/problems-installing-home-and-business-sunset-edition-in-windows-10?forum=money#7e7e8fc5-6235-4efa-a122-937f7d79831b

    Did you try either of the solutions that I proposed then?  Any luck?

    Note that the registry modification for IE6 is no longer required and is not recommended.  And if you get up and running, be sure to look at the first "Sticky" thread in this forum:

    https://social.microsoft.com/Forums/en-US/d28d6921-1f01-430f-b33e-f5a3ec47077b/important-patch-for-money-plus-maybe-20062007-mnyob99dll?forum=money

    and do the mnyob99.dll replacement.


    Bill Becker

    Tuesday, January 30, 2018 4:00 PM
  • In your older post, you mentioned that you had Money 2005 Business. Which country was that install? If it was not US, you cannot convert those Money files to Sunset. Money files are strictly limited to being opened in the version of Money for a specific country and cannot open in a program created for a different country.

    To get 2005 to reinstall, you must use the correct link in the second "sticky" post. Any CD you may have from an original purchase will not have the correct updates, and your Money data file has already been upgraded to an updated version of 2005. You need to download the copy that already has the updates since Money cannot update itself any longer. All the Microsoft servers that supported that update were retired years ago.


    Bob - MSN Mobile

    Tuesday, January 30, 2018 7:44 PM
  • Yes I have tried the previous suggestions with no luck. Not sure how these threads work since I have never used a forum so apologize about the double posting. Also not sure if I have to respond to each individual response or everyone sees everything? A little more information. I am running a windows 10 64 bit system which I have had for years. I had Money Business sunset installed and have been using it fo years also. Suddenly after 12/16/17 it quit working. That's why I have been trying to reinstall the Business sunset version with no luck.

    I originally had a US version of Money Small business 2005, I can still install that version but all my files have been converted for the sunset version. I tried installing the 2005 version to see if I could get the sunset version to upgrade from an installed program, but again no luck.

    The event viewer and the SxsTrace program report the same issue which is

    "Activation context generation failed for "C:\Program Files (x86)\Microsoft Money Plus\MNYCoreFiles\MNYSL08.dll". Dependent Assembly Microsoft.VC80.ATL,processorArchitecture="x86",publiKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50608.0" could not be found. Please use sxstrace.exe for detailed diagnosis."

    Haven't been able to find this version for the VC80.ATL reference. Assuming something got corrupted in my registry but at a loss at this point as to how to fix issue.

    Wednesday, January 31, 2018 8:45 PM
  • see reply for Bill Becker above
    Wednesday, January 31, 2018 8:45 PM
  • 1. Everybody sees everything.

    2. Try right-clicking the install file, and choose RunAsAdminstrator.

    Wednesday, January 31, 2018 9:08 PM
    Moderator
  • If Cal's suggestion doesn't work there may be a Windows system problem.   

    I am totally unqualified to interpret that error message, but this link:

    https://www.howtogeek.com/222532/how-to-repair-corrupted-windows-system-files-with-the-sfc-and-dism-commands/

    gives some ways of checking for corrupted system files.  The sfc /scannow command is easy and might give some insight.  


    Bill Becker

    Wednesday, January 31, 2018 9:11 PM
  • From the date when the problem occurred I think something in the December 2017 Cumulative Update to Windows 10 triggered the problem.

    You will not find the solution easily. Windows has a SXS (side by side) system where it stores separate copies of files used by many programs so that each program uses is own copy of the file. Something has gone wrong in the indexing of those files.

    If you are not expert in the SXS system, the easiest way – least time consumingis probably to back up your data and settings, wipe your system and clean install Windows 10 and your programs.

    See Create Windows 10 installation media for installation media for the 1709 Fall Creators Update.

    Thursday, February 1, 2018 9:34 AM
  • Finally got enough time to run the SFC scan. first time found corrupted files but couldn't fix them, then ran the DISM program successfully. Rand SFC scan again and found corrupted files and repaired them. ran it again with clean bill of health. However, didn't fix installation issue with Money Sunset Version. Still says its looking for an older version of the VC80.atl file.(8.0.50608.0). downloaded the installation file for this version from Microsoft and tried running it but it starts to install and then just stops?
    Monday, February 5, 2018 12:11 AM
  • OK, so there was (and maybe still is) a problem with your Windows installation. 

    Have you had any other problems that might lead you to suspect a failing hard drive or intermittent memory problems?

    In any event, I think that DominicP's advice ablove is your best bet.  Trying to repair your system will be time-consuming and might not be successful.  It's painful to back up all your data and reinstall every program but it might be less work than continuing to investigate the error and it does give a clean installation.  Or maybe you have a system image from before 12/16/17?


    Bill Becker

    Monday, February 5, 2018 2:17 AM
  • You could try creating a new Windows administrator user, and try doing the install as that user.
    Monday, February 5, 2018 5:42 AM
    Moderator