locked
Domain Verification live.azure.com RRS feed

  • Question

  • Hi,

    We are having an issue verifiying our domain. We placed the text file at the root of the website. The website and text file are accessible from inside our network as well as outside our network on web port 80.

    Below is the error we receive when trying to verify the domain.

    We were unable to locate the file "filename.txt" at crm.company.com. To fix this issue, try the following:

    • Make sure the URL of your domain is spelled correctly.
    • Check the spelling and case of the file name. Many web servers are case-sensitive.
    • Confirm that the file "filename.txt" is located in the root directory of your server.

    Please help!

    Thursday, May 5, 2011 2:18 PM

Answers

  • You should carefully read the instructions.  Setting up Live ID is quite a process.  You cannot put what you think of as a live id anywhere in the contact record.  Live Id will issue a UUID for the user, and the only way to implement Live ID will be with the invitation mechanism.  The portal also uses a challenge / response mechanism.  The documentation covers this but you will have to carefully follow it.  Most mistakes have been made previously by many other users, and the best place to read all of the errors made and the fixes for them is in the discussions on the CRM 4 version of the customer portals on codelex.  The mechanism has not changed since CRM 4.  Take a look at the solutions in this forum: http://customerportal.codeplex.com/discussions
    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com
    • Proposed as answer by Palak Kadakia Monday, May 16, 2011 4:55 PM
    • Marked as answer by Jim Glass Jr Tuesday, May 24, 2011 6:28 PM
    Saturday, May 7, 2011 4:15 AM
    Moderator
  • Finally figured it out. Was a port issue, as we had the portal on port 8080.

     

    • Proposed as answer by Palak Kadakia Monday, May 16, 2011 4:55 PM
    • Marked as answer by Jim Glass Jr Tuesday, May 24, 2011 6:28 PM
    Monday, May 9, 2011 5:56 PM

All replies

  • This issue is resolved now. We were able to verify the domain. Now on to the next problem- Signing in to portal. Attempting to sign in to portal with live ID created for creating the Application settings in live.azure.com. Sign in does nothing. Admin user was created in CRM with active directory username and LiveID email. There is probably a disconnect here. Can someone throw a hint out for this hoopefully last step.

    Oh, the pain! :) 

    Thursday, May 5, 2011 3:19 PM
  • You should carefully read the instructions.  Setting up Live ID is quite a process.  You cannot put what you think of as a live id anywhere in the contact record.  Live Id will issue a UUID for the user, and the only way to implement Live ID will be with the invitation mechanism.  The portal also uses a challenge / response mechanism.  The documentation covers this but you will have to carefully follow it.  Most mistakes have been made previously by many other users, and the best place to read all of the errors made and the fixes for them is in the discussions on the CRM 4 version of the customer portals on codelex.  The mechanism has not changed since CRM 4.  Take a look at the solutions in this forum: http://customerportal.codeplex.com/discussions
    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com
    • Proposed as answer by Palak Kadakia Monday, May 16, 2011 4:55 PM
    • Marked as answer by Jim Glass Jr Tuesday, May 24, 2011 6:28 PM
    Saturday, May 7, 2011 4:15 AM
    Moderator
  • Finally figured it out. Was a port issue, as we had the portal on port 8080.

     

    • Proposed as answer by Palak Kadakia Monday, May 16, 2011 4:55 PM
    • Marked as answer by Jim Glass Jr Tuesday, May 24, 2011 6:28 PM
    Monday, May 9, 2011 5:56 PM