locked
Dynamics CRM-Deployment Manager-MMC Could not create the snap in- RRS feed

  • Question

  • Hello nice people.

    Please your kind help:

    We have installed CRM in 3 Server: APP, WEB Y BD.  When we try to open Web Server to create the Organization, the following error appears:

     MMC Could not create the snap in

    Nothing else is shown. Checking the Event Viewer we don´t see any CRM error.

    Our Architecture has:

    • 2 Domain Controllers in Windows 2008, which replicate each other.
    • CRM is installed Azure platform

    Checking other forums:

    • We set  in regedit HKLM/SOFTWARE/Microsoft/MSCRM/ the String Entrance: PreferredDC with the value:  NombreDelDomainController where the CRM OU exists.  This was done in Web & APP

    Thanks in advanced for your help.

    -Roxana


    Roxana Cevallos Q. -PARTNER-

    Friday, November 14, 2014 12:20 AM

Answers

  • Hello, The problem is solved.

    We did the following:

    1-Verify and added the permissions in ActiveDirectory for all service accounts. 

    2-Verify and added some permissions to the SQL Server.

    3-Verify and added permissions in Group Policies Local in gpedit of the Web an App Server, to execute the mmc.

    4-We uninstall and install the CRM. And in this second install we could enter the credentials of the Deployment Web Service. In the first installation, these credentials weren´t asked.

    Now the Deployment Manager is working and we could create the organization.

    Thanks.


    Roxana Cevallos Q. -PARTNER-

    Thursday, November 20, 2014 11:45 PM

All replies

  • hi Roxana,

    please try to restart the server. The mmc expects connection string to the mscrm_config database to be correct. I suspect that the registry edit may be the issue. Please restore your registry key before edit to see if that resolves the issue?.

    regards

    Jithesh

    Saturday, November 15, 2014 12:18 PM
  • Hello, Thanks for ypur reply.

    I have restarted the 3 server for many times. I have checked the regedit: HKLM\SOFTWARE\MICROSOFT\MSCRM:  Data Source=namebdinstance;Initial Catalog=MSCRM_CONFIG;Integrated Security=True;Connect Timeout=60

    I have also checked:

    -The Permissions of services accounts and groups in Active Directory, SQL Server and the Local Servers.

    -The Local Policies Group of the Web and App Server to check if MMC are available to open.

    All the architecture is implemented in windows azure.

    Don´t know what else.


    Roxana Cevallos Q. -PARTNER-

    Sunday, November 16, 2014 3:37 PM
  • hi,

    can you please check the log file under appdata\roaming\Microsoft\mscrm for further information?.

    regards

    Sunday, November 16, 2014 8:59 PM
  • Hello, The problem is solved.

    We did the following:

    1-Verify and added the permissions in ActiveDirectory for all service accounts. 

    2-Verify and added some permissions to the SQL Server.

    3-Verify and added permissions in Group Policies Local in gpedit of the Web an App Server, to execute the mmc.

    4-We uninstall and install the CRM. And in this second install we could enter the credentials of the Deployment Web Service. In the first installation, these credentials weren´t asked.

    Now the Deployment Manager is working and we could create the organization.

    Thanks.


    Roxana Cevallos Q. -PARTNER-

    Thursday, November 20, 2014 11:45 PM