locked
Error message on installation of CRM 2013 - Action Microsoft.Crm.Tools.Admin.SetTokenKeyAction failed. RRS feed

  • Question

  • Hi all,

    I'm doing my first installation of CRM 2013 and I've got a message near the end of the install:

    Action Microsoft.Crm.Tools.Admin.SetTokenKeyAction failed. Name translation: Generic processing error. (Exception from HRESULT: 0x80072115)

    Has anyone seen this before? Is it something I need to worry about? Could I ignore this?

    Tuesday, July 15, 2014 3:53 PM

All replies

  • Hi,

    Before installing Dynamics CRM, did you re-verify that you have all the pre-requisites like permissions, etc.?


    Admin QuikView Solution for CRM 2013

    Wednesday, July 16, 2014 6:20 AM
  • Hi,

    Thanks for replying. As far as I know, we did set up all of the permissions.

    When we started the install, it stopped quite quickly as there were some permission issues on the front end server but these were solved and the installation started.

    Is there anything specific I need to set up on the database server? I've just logged on to it and I can see that the default environment has got a database in there as well as the MSCRM_CONFIG database.

    Wednesday, July 16, 2014 8:23 AM
  • Hi,

    I guess the error prevented the creation of your Organization database, for example ORGNAME_MSCRM? Do you have anything in the event viewer or in the log file after the installation went wrong?


    Admin QuikView Solution for CRM 2013

    Wednesday, July 16, 2014 9:25 AM
  • Hi,

    No, the database has been created - it created 2 databases; ORGNAME_MSCRM and MSCRM _CONFIG which is what I would expect. There's also nothing in the event log that relates to this - I've tried clicking on the 'Retry' button of the error message and nothing's added to the log.

    Wednesday, July 16, 2014 9:28 AM
  • Hi,

    Are you able to access Dynamics CRM? Does everything apparently seem to work fine?


    Admin QuikView Solution for CRM 2013

    Wednesday, July 16, 2014 10:28 AM
  • Hi,

    It doesn't look like it. I've gone onto the server and tried to access http://localhost but get the message:

    An error has occurred.

    Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.

    Wednesday, July 16, 2014 11:09 AM
  • Ah, I was guessing that! Could you possibly run a trace and check what might be the issue? See here how to run a trace.

    It would be best to uninstall and reinstall CRM once more and check if that error appears again.


    Admin QuikView Solution for CRM 2013

    Wednesday, July 16, 2014 11:21 AM