locked
Cannot format drive, could not install Windows Home Server (hair pulling, cursing, and the like) RRS feed

  • General discussion

  • Hello group, this is my first post.  I reading your rules, so i hope this is useful and appropriately posted.

    I was stuck for a over a week trying to install WHS, so I thought I would share this.  I have a very old Dell Dimension 4300 (2.53GHZ/P4/1GB) that I was about to chuck, but saw WHS and thought 'hey, neat!  I can dump my home sharepoint site in favor of WHS on an old Dell'...

    So i bought several new Hitachi 500GB PATA hard drives (i think they are Hitachi P75K500, 7200RPM, PATA-133, very old school...) to replace the even older 80GB drive and tried to install WHS.  The 500GB drives showed up fine in the BIOS, but WHS refused to install, it would get past the HD format problem, but it fail every single operation after that.  I got messages similar to the messages in this thread (but they are using SATA/RAID, so I don't think its the same problem):

    http://social.microsoft.com/Forums/en-US/whssoftware/thread/5320e3ab-dc3f-4b0c-9feb-e4bef369a283/

    But the drives were passing a Seagate drive testing CD i had on hand, they appeared fine.  From the error logs, it seemed like the installer wasn't able to write to the new formatted partition.  I read all kinds of things on this site and others... like replace the DVD-ROM drive (which i did, to absolutely no avail), try to slip-stream the installer on a thumb drive (couldn't get it to work), I cycled through various BIOS settings, I cycled through the HD's, I used another power supply, and eventually I literally pulled my 80GB HD out of the trash and put it back in to the machine, and still WHS would not install, it would not get past the formatting HD screen.  I noticed however that I could not install any other operating systems either. Eventually after trying all sorts of things, I removed everything, put my 80GB HD and DVD-ROM on the same IDE, and finally WHS installed.

    After WHS was up and running (with very little storage space), I tried to add the 500GB hard drives, but I could never get the drives to work.  I tried to format it first through the WHS console interface, but it would give me an error after formatting the drive.  Next i tried to directly format the drives through the Windows Disk Management interface.  Then I tried through command line tools.  None of these worked, they would get halfway through the format, then would die with a message like "windows was unable to complete the format", or they would pass the format, but I would not be able to mount the partition.  CHKDSK would not run on the half/formatted partitions.  If you search the web, you will lots of people with this problem with all sorts of drives caused by all kinds of reason.

    I went to Hitachi's site and downloaded/burned their Drive Fitness Tool utility, I tested two of the drives with the thorough tests, and the drives seemed to be 100% fine, no problems reported.  I was looking at their other tools and found the answer.  If only i saw this sooner:

    http://www.hitachigst.com/hdd/support/qcheck.htm#a11

    Solution:  The drives supported up to UDMA 6, but I guess the Dell system was only capable of UDMA 5.

    I really don't know exactly what that means, but to fix the problem, I downloaded Hitachi's "Feature Tool Utility" from http://www.hitachigst.com/hdd/support/download.htm.  I changed the UDMA speed for every single HD from 6 to 5, saved, power cycled, and all my problems were solved.

    So the short version of this post is:  If you have partitioning problems on an old computer, or WHS won't install because of copy errors right after formatting the partition, make sure to check the UDMA speed on your HD.  I hope this helps someone in the future.

    • Edited by CCorey Thursday, May 20, 2010 6:54 PM (slight correction)
    • Changed type Olaf EngelkeModerator Thursday, May 20, 2010 8:38 PM Not a question.
    Thursday, May 20, 2010 6:50 PM

All replies

  • Thanks for this helpful information.

    Best greetings from Germany
    Olaf

    Thursday, May 20, 2010 8:47 PM
    Moderator