none
VS 2017 Tools

    Question

  • Been using VS C++6.0, was suggested to download and use VS 2017, supported better for Win 10. I did this, opened my C++6.0 source file. Now, tried to compile but said "no Extensions". Therefore, looked up extensions for C++ compilation, recommendation to use the Microsoft C++ compiler so downloaded as extension. Tried the compile, seemed to work but the system is complaining that it cannot find some of my directives, i.e. include <windows.h>. I am using the OpenGL included libraries and some of the math libraries, i.e. include <math.h>. Are the included libraries also in an extension or? Please help, do I need to include every possible code used as extensions or? Thanks, Sid kraft
    Wednesday, May 30, 2018 3:10 PM

All replies

  • Please provide the entire error message; I have been using the VC compiler since the first version and the Microsoft C compiler before that. I have no idea what "no extensions" means. I don't know of any compiler extensions, especially not that are require for the compiler.

    You should either uninstall the extension you installed or provide more information about it since it could affect something that someone suggests here.

    Please provide a link to any recommendation you acted on.



    Sam Hobbs
    SimpleSamples.Info

    Wednesday, May 30, 2018 10:09 PM
  • Sam: Tried to submit the sample page to you on the compiler output, got an error from this site that said body must be 4 to 60000 characters long, bogus!!!!!!!!!!!!!!!!!! Sid Kraft Let me know how to provide a "link" as you say
    Friday, June 1, 2018 3:04 PM
  • Sam: Image below of the compiler errors that I talked about on #include <nnnn>

    Sunday, June 3, 2018 1:35 AM
  • One big problem is that this is a C++ question. I don't know why you put this question in the Visual Studio Diagnostics (Debugger, Profiler, IntelliTrace) forum. Also you would get more help from people most qualified to help if you used a title that described the problem better. So you would get better help in the C++ language forum and with a more relevant title. Also, there is probably a relevant question with a good answer.

    A couple of days ago I tried to modify a project I created quite recently and it does not work either. Somehow the directory with the include files got deleted. One big part of the problem is that Microsoft supports very many versions of Windows and the way that they do that appears to be vulnerable (fragile). So I need to figure out how to fix the project I have because it probably applies to many of my other projects. I might have a suggestion for you too. In the process, I will likely search for previous questions in the C++ language forum relevant to this.



    Sam Hobbs
    SimpleSamples.Info

    Sunday, June 3, 2018 3:40 AM
  • Thanks Sam. will do, Sid Kraft
    Monday, June 4, 2018 4:08 PM