locked
Upgrade fron CRM 2011 to 2013 (in place) on test Environment RRS feed

  • Question

  • I an testing the upgrade in a test environment that I have set up.

    I rename the database from CRMtest_MSCRM to CRM_MSCRM to have the sane name as production

    However when starting the upgrade there is an error:

     "Cannot open database "CRMtest_MSCRM" requested by login.
      The login failed.    Login failed for User  "domain\nick"

    This user exists in SQL but the database name is now CRM_MSCRM  
    and not  CRMtest_MSCRM as referenced in the error.

    Where do I need to make the change so it can reference the correct database name?

    Thanks

    Nick


    Nick M

    Wednesday, February 15, 2017 3:19 PM

Answers

  • There are 2 ways to do this, both using CRM Deployment Manager:

    1. Disable the CRMTest organistion, then Edit. This will allow you to change the database name and/or connection. Then reenable the organisation. This is the quicker approach, but there are some circumstances when it may not work
    2. Disable the CRMTest organistion, then Delete. Then import the organisation from the CRM_MSCRM database

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    • Marked as answer by NickMangioros Wednesday, February 15, 2017 8:25 PM
    Wednesday, February 15, 2017 4:56 PM
    Moderator
  • Deleted the disabled CRMTest organization within the Deployment Manager

    resolved the issue


    Nick M

    • Marked as answer by NickMangioros Thursday, February 16, 2017 1:38 PM
    Wednesday, February 15, 2017 8:24 PM

All replies

  • There are 2 ways to do this, both using CRM Deployment Manager:

    1. Disable the CRMTest organistion, then Edit. This will allow you to change the database name and/or connection. Then reenable the organisation. This is the quicker approach, but there are some circumstances when it may not work
    2. Disable the CRMTest organistion, then Delete. Then import the organisation from the CRM_MSCRM database

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    • Marked as answer by NickMangioros Wednesday, February 15, 2017 8:25 PM
    Wednesday, February 15, 2017 4:56 PM
    Moderator
  • Thanks for your response.

    I had two in the List 
         - CRMtest_MSCRM    <- was disabled but was using this to connect to the valid one
         - CRM_MSCRM          <- enabled and correct

    Deleted the disabled one and will try again.

    Will let you know.

    Thanks


    Nick M

    Wednesday, February 15, 2017 7:24 PM
  • Deleted the disabled CRMTest organization within the Deployment Manager

    resolved the issue


    Nick M

    • Marked as answer by NickMangioros Thursday, February 16, 2017 1:38 PM
    Wednesday, February 15, 2017 8:24 PM