locked
Https setting for Microsoft Translator RRS feed

  • Question

  • Hi,

    I have set up the Microsoft Translator in Windows 7 as well as the account. However I dont see any setting to ensure that document upload and download of translation happens vis https. How is this accomplished ?

    Thanks,

    Monday, September 28, 2015 10:04 PM

Answers

  • Hi Anushil,

    can you describe which application you are using to translate documents? The Document Translator (http://www.microsoft.com/en-us/translator/doctranslator.aspx) always uses SSL for communicating with the server, there is no other option. Microsoft Office 2016 also uses SSL exclusively. Earlier versions of Office do not use SSL for document translation, and there is no option to change this within these older version of Office.

    When you are writing your own application, simply connect using https, and you will have all traffic encrypted.

    The Bing Translator widget will use SSL if the page it sits on is on an https site.

    Let us know if this answers the question,
    Chris Wendt
    Microsoft Translator

    Tuesday, September 29, 2015 2:43 AM

All replies

  • Hi Anushil,

    can you describe which application you are using to translate documents? The Document Translator (http://www.microsoft.com/en-us/translator/doctranslator.aspx) always uses SSL for communicating with the server, there is no other option. Microsoft Office 2016 also uses SSL exclusively. Earlier versions of Office do not use SSL for document translation, and there is no option to change this within these older version of Office.

    When you are writing your own application, simply connect using https, and you will have all traffic encrypted.

    The Bing Translator widget will use SSL if the page it sits on is on an https site.

    Let us know if this answers the question,
    Chris Wendt
    Microsoft Translator

    Tuesday, September 29, 2015 2:43 AM
  • Thanks Chris ! We are using the Microsoft Translator for Windows so your answer confirms my assumption.


    Tuesday, September 29, 2015 4:34 AM