none
Error en Dashboard:"Se ha superado el límite máximo de registros. Reduzca el número..." RRS feed

  • Pregunta

  • Hola amigos.

    Tengo el siguiente problema:

    Cuando construyo un gráfico (Cono) para un dashboard a partir de una tabla con más de 55000 registros (Contact), obtengo el siguiente mensaje de error:

    "

    Se ha superado el límite máximo de registros. Reduzca el número de registros":

    A continuación la imagen del error y el fetch resultante del gráfico construido por medio del CRM.

    Agradezco ideas para solucionar este inconveniente y generar gráficos con tablas con muchos registros.

    <visualization>
      <visualizationid>{xxxxx-xxxxx-xxxxx-xxxxx-xxxxx}</visualizationid>
      <name>EstadoP</name>
      <primaryentitytypecode>contact</primaryentitytypecode>
      <datadescription>
        <datadefinition>
          <fetchcollection>
            <fetch mapping="logical" aggregate="true">
              <entity name="contact">
                <attribute groupby="true" alias="_CRMAutoGen_groupby_column_Num_0" name="new_estadoparticipante" />
                <attribute alias="_CRMAutoGen_aggregate_column_Num_0" name="fullname" aggregate="count" />
              </entity>
            </fetch>
          </fetchcollection>
          <categorycollection>
            <category alias="_CRMAutoGen_groupby_column_Num_0">
              <measurecollection>
                <measure alias="_CRMAutoGen_aggregate_column_Num_0" />
              </measurecollection>
            </category>
          </categorycollection>
        </datadefinition>
      </datadescription>
      <presentationdescription>
        <Chart Palette="None" PaletteCustomColors="149,189,66; 197,56,52; 55,118,193; 117,82,160; 49,171,204; 255,136,35; 168,203,104; 209,98,96; 97,142,206; 142,116,178; 93,186,215; 255,155,83">
          <Series>
            <Series ChartType="Bar" IsValueShownAsLabel="True" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="PointWidth=0.75, MaxPixelPointWidth=40">
              <SmartLabelStyle Enabled="True" />
            </Series>
          </Series>
          <ChartAreas>
            <ChartArea BorderColor="White" BorderDashStyle="Solid">
              <AxisY LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
                <MajorGrid LineColor="239, 242, 246" />
                <MajorTickMark LineColor="165, 172, 181" />
                <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
              </AxisY>
              <AxisX LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
                <MajorTickMark LineColor="165, 172, 181" />
                <MajorGrid LineColor="Transparent" />
                <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
              </AxisX>
            </ChartArea>
          </ChartAreas>
          <Titles>
            <Title Alignment="TopLeft" DockingOffset="-3" Font="{0}, 13px" ForeColor="59, 59, 59"></Title>
          </Titles>
        </Chart>
      </presentationdescription>
      <isdefault>false</isdefault>
    </visualization>

    martes, 26 de junio de 2012 14:32

Todas las respuestas

  • Hola hay una solución, pero es no soportada y solo funciona para CRM onpremise.

    tienes que ir a la base de datos MSCRM_Config a la tabla DeploymentProperties y aumentar el campo AggregateQueryRecordLimit y TotalRecordCountLimit a -1.

    esto lo debes de hacer mediante un "update" de SQL.

    un saludo,


    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com

    jueves, 28 de junio de 2012 11:06
    Moderador
  • CRM admite como mucho 50.000 registro a menos que lo cambies en  la base de datos

    jueves, 26 de julio de 2012 21:23