none
Error al quitar un valor de relación con otra entidad RRS feed

  • Pregunta

  • Hola a todos, en la entidad de cuentas tengo un campo relacionado con otra entidad y quiero quitarle el valor. Al pulsar 'Quitar valor' me lo quita correctamente pero cuando le doy a guardar me dice lo siguiente:

    No se puede cambiar el nombre de inicio de sesión en el dominio

    No dispone de los permisos necesarios para cambiar el nombre de inicio de sesión en el dominio para este usuario.

    Me descargo el archivo de registro y tiene lo siguiente:

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Access is denied.Detail:
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147187707</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>Access is denied.</Message>
      <Timestamp>2012-05-23T16:24:44.1422993Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText>

    [SBPlugin: SBPlugin.cPlugInsertERPClien]
    [46716ba5-e6a4-e111-bf25-001a64b6dedc: SBPlugin.cPlugInsertERPClien: Update of account]

    </TraceText>
    </OrganizationServiceFault>

    Estoy haciendolo con el Administrador del servidor, estoy trabajando con el CRM2011. Os agradeceria que me ayudaseis con este problema.

    Gracias.

    miércoles, 23 de mayo de 2012 16:32

Respuestas

  • Muchas gracias frank ya lo he podido arreglar, la verdad es que el error no era muy explicativo, el problema venia dado por un valor nulo.

    Muchas gracias nuevamente.

    • Marcado como respuesta SBCristobal jueves, 24 de mayo de 2012 16:09
    jueves, 24 de mayo de 2012 16:09

Todas las respuestas

  • Saludos,

    Por el tipo de error me parece que debes verificar los privilegios de seguridad, en la instancia de CRM, del usuario que estas utilizando. Veo que se esta disparando un Plugin (SBPlugin.cPlugInsertERPClien), por lo cual te sugiero que verifiques lo que se esta modificando el mismo y asi poder identificar que roles debes añadir a ese usuario. 


    Frank Hernández | http://www.elblogcrm.com/http://www.twitter.com/ElBlogCRM | http://www.facebook.com/ElBlogCRM

    If you consider this post as helpful please Vote as Helpful and/or Mark as Answer. Thanks you!

    Si usted considera esta respuesta como útil por favor márquela como Útil y/o márquela como Respuesta. Gracias!

    jueves, 24 de mayo de 2012 10:46
  • Muchas gracias frank ya lo he podido arreglar, la verdad es que el error no era muy explicativo, el problema venia dado por un valor nulo.

    Muchas gracias nuevamente.

    • Marcado como respuesta SBCristobal jueves, 24 de mayo de 2012 16:09
    jueves, 24 de mayo de 2012 16:09