none
Error CRM - Reporting Services RRS feed

  • Pregunta

  • Buenos dias.

    Desarrolle un reporte con un store procedure, el cual es muy demorado en ejecutarse (20-30min),,, el problema que tengo es que cuando cargo el informe al CRM  y lo ejecuto desde ahi, empieza la ejecucion y al tiempo me aparece en blanco y un "error on page" en la parte inferior de la pantalla... he intentado aumentandole el timeout en el IIS, en el DS del reporte,,,, pero no me funciona,,,, alguien tiene alguna idea de como puedo solucionar esto? que asi el reporte se demore, este se pueda visualizar desde CRM.

    Gracias.

    jueves, 12 de julio de 2012 13:34

Todas las respuestas

  • Hola Diegob3,

    Le podrías aumentar el timeout del report. Mira el siguiente link.

    http://blogs.msdn.com/b/jgalla/archive/2006/10/11/session-timeout-during-execution.aspx

    Salu2

    Atilin


    Salu2 Atilin | http://atiliorosas.blogspot.com.es/

    jueves, 12 de julio de 2012 14:20
  • Hola Diego,

    Creo que adicionalmente a lo que Atilio comenta, podes tratar de optimizar la consulta que has generado. La verdad sería muy precipitado darte una alternativa porque no conocemos bien la estructura de la misma consulta.

    Analiza la posibilidad de crear tablas temporales donde pre filtres el contenido de la información a mostrar, es probable que haciendo esto puedas reducir los tiempos de respuesta de tu consulta.

    Sugiero también que con ayuda del analizador de consultas del SQL puedas examinar en que parte, la consulta esta consumiendo mas recursos y tratar de optimizarla.

    Espero haberte ayudado, un abrazo.


    [MVP]-Microsoft Dynamics CRM | My blog: http://jimmylarrauri.blogspot.com | My twitter: http://twitter.com/jimlarrauri

    viernes, 13 de julio de 2012 3:27
    Moderador
  • hola Jimmy y Atilio,,,

    gracias por sus respuestas,,, el problema que tengo es que el reporte tiene muuchos datos, y ademas de eso tengo que comparar datos del año actual vs el pasado,,, creo que la consulta esta bien, no veo como poder optimizarla mas de lo que esta,,, quisiera saber que hacer para que cuando ejecute el reporte desde el CRM, este se muestre,, asi se demore.. yo creo que puede ser algo con el timeout o no se si modificar algo mas...

    gracias.

    viernes, 13 de julio de 2012 15:47