none
CRM 2011- ERROR al intentar subir un pluggin- por favor a alguien ha sufrido un error parecido. gracias RRS feed

  • Pregunta

  • error: <v:shapetype coordsize="21600,21600" filled="f" id="_x0000_t75" o:preferrelative="t" o:spt="75" path="m@4@5l@4@11@9@11@9@5xe" stroked="f">
    </v:shapetype>

    Unhandled Exception: System.InvalidOperationException: The provided uri did not return any Service Endpoints!

       en Microsoft.Xrm.Sdk.Client.ServiceConfiguration`1..ctor(Uri serviceUri)

       en Microsoft.Xrm.Sdk.Client.ServiceConfigurationFactory.CreateConfiguration[TService](Uri serviceUri)

       en Microsoft.Xrm.Sdk.Client.ServiceProxy`1..ctor(Uri uri, Uri homeRealmUri, ClientCredentials clientCredentials, ClientCredentials deviceCredentials)

       en PluginRegistrationTool.CrmConnection.get_DiscoveryService() en D:\CRM2011SDK\sdk\tools\pluginregistration\CrmConnection.cs:línea 258

       en PluginRegistrationTool.CrmConnection.RetrieveOrganizations() en D:\CRM2011SDK\sdk\tools\pluginregistration\CrmConnection.cs:línea 315

       en PluginRegistrationTool.ConnectionsForm.OpenConnection(CrmConnection con) en D:\CRM2011SDK\sdk\tools\pluginregistration\ConnectionsForm.cs:línea 940

    <v:shapetype coordsize="21600,21600" filled="f" id="_x0000_t75" o:preferrelative="t" o:spt="75" path="m@4@5l@4@11@9@11@9@5xe" stroked="f">  <v:stroke joinstyle="miter">
      <v:formulas>  <v:f eqn="if lineDrawn pixelLineWidth 0">
      Hemos estado trabajando con el dopetarmwento de IT y no hemos encontrado nada distinto a otras veces que si han subuido los pluggins.<v:f eqn="sum @0 1 0">
      <v:f eqn="sum 0 0 @1">
      gracias por vuestra ayuda<v:f eqn="prod @2 1 2">
      <v:f eqn="prod @3 21600 pixelWidth">
      <v:f eqn="prod @3 21600 pixelHeight">
      <v:f eqn="sum @0 0 1">
      <v:f eqn="prod @6 1 2">
      <v:f eqn="prod @7 21600 pixelWidth">
      <v:f eqn="sum @8 21600 0">
      <v:f eqn="prod @7 21600 pixelHeight">
     <v:f eqn="sum @10 21600 0">
    </v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:formulas>
     <v:path gradientshapeok="t" o:connecttype="rect" o:extrusionok="f">
    <o:lock aspectratio="t" v:ext="edit">
    </o:lock></v:path></v:stroke></v:shapetype><v:shape alt="" id="Imagen_x0020_2" o:spid="_x0000_i1025" style="width:461.25pt;height:246pt;" type="#_x0000_t75">
    <v:imagedata o:href="cid:image001.png@01CD5A05.1529CE10" src="file:///C:\Users\Natalia\AppData\Local\Temp\msohtmlclip1\01\clip_image001.png">
    </v:imagedata></v:shape>
    viernes, 6 de julio de 2012 7:18

Todas las respuestas

  • Normalmente este error se debe a que la herramienta de registro de plug-ins no encuentra el "discovery.svc" service.

    Puedes comprobar que tu servicio para el registro de plugins es accesible en

    http://NOMBRE_MAQUINA:PUERTO/xrmservices/2011/Discovery.svc

    Si estas intentando usar "localhost" como nombre de la maquina prueba a cambiarlo por su nombre completo. Una vez que des con el nombre correcto donde está el servicio deberías poder registrar el plugin sin problemas.




    • Propuesto como respuesta Jose A. Lozano martes, 24 de julio de 2012 12:44
    lunes, 9 de julio de 2012 13:34