none
consulta depurar plugin RRS feed

  • Pregunta

  • Estimados, estoy tratando de depurar un plugin con VS2008 estoy siguiendo los pasos que indican en una pagina que son:

    1. copiar dll y pdb a la carpeta bin del CRM

    2. en opcion debug, atachar el proceso w3wp.exe, el cual no encuentro alguien sabe si debo habilitar algo para uqe aparesca?

     

    saludos y gracias

     

    jueves, 7 de julio de 2011 21:17

Todas las respuestas

  • Hola CarlosMupe, si no te aparece puede ser porque hayas hecho un iisreset o algo asi no?

    entra al CRM (al ejecutar el CRM, deberias poder ver el proceso w3wp.exe)...

    un saludo


    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com
    viernes, 8 de julio de 2011 10:20
    Moderador
  • Estimado, tengo la pagina abierta del CRM, ojo que no esta instalado en mi PC (esta en el servidor de desarrollo), estoy tratando de depurar desde mi PC con WINXP, sera por eso que no me figura este proceso?

     

    saludos y gracias

    viernes, 8 de julio de 2011 13:28
  • Estimado, logre encontrar el proceso, lo atacho y le pongo los puntos de interrupcion a la aplicacion, ademas de copiar los respectivos PDB a la carpeta bin del crm, el tema es que no levanta el VS2008 cuando gatilla el PlugIn que podra ser?

     

     

    saludos y gracias por sus respuestas

    viernes, 8 de julio de 2011 16:27
  • Hola Carlos, efectivamente, en tu "local" no podrás depurar el "plugin". Te en cuenta que el plugin se ejecuta en el proceso w3wp.exe que esta en ejecucion en el servidor y no en tu local.

    Hay alguna forma de realizar esto con depuracion "remota", o sea desde un VS2008 que tengas en tu ordenador local, y conectandote en vez de a tu orednador local, al servidor (aunque sinceramente nunca logré que me funcione esto correctamente).

    De todos modos, creo que la mejor forma es tener instalado en el servidor el VS2008 y depurar en el mismo servidor (debería ser un servidor de desarrollo).

    un saludo


    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com
    lunes, 11 de julio de 2011 7:21
    Moderador
  • Estimado, gracias por tu respuesta, efectivamente tengo un servidor desarrollo con vs2008 y trato de depurar realizando todos los pasos, pero al momento de ejecutar la aplicacion no levanta la depuracion el vs2008 alguna idea de que podra ser?

     

    saludos y gracias

    lunes, 11 de julio de 2011 13:21
  • entonces no se por que puede ser. te hago algunas preguntas:

    - en que mensaje y entidad esta registrado?

    - la dll la tienes firmada? la estas registrando en la base de datos?

    - entiendo que el visor de sucesos no esta dando ningun error y el plugin funciona, pero no puedes depurarlo no?

    - es un plugin sincrono o asincrono? si es asincrono debes adjuntarte a otro proceso (CRMASyncservice.exe)

    un saludo


    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com
    miércoles, 13 de julio de 2011 7:11
    Moderador
  • Estimado, gracias por la respuesta, respondo a tus preguntas:

    - en que mensaje y entidad esta registrado?

    R:create, entidad contact

    - la dll la tienes firmada? la estas registrando en la base de datos?

    R: esta firmada y registrada con el plugin registration tools, copie la DLL y el PBD al directorio server\bin del CRM 4

    - entiendo que el visor de sucesos no esta dando ningun error y el plugin funciona, pero no puedes depurarlo no?

    R:efectivamente el plug in funciona, pero no abre la depuracion del vs2008

    - es un plugin sincrono o asincrono? si es asincrono debes adjuntarte a otro proceso (CRMASyncservice.exe)

    R: es sincrono y es llamado en el post

     

    saludos y gracias

    miércoles, 13 de julio de 2011 14:53