none
Reporting Errors CRM 4.0 RRS feed

  • Pregunta

  • Hola a Todos(as)..

    Tengo un Windows 2003 full updates y en el tengo instalado CRM 4.0, en el mismo server se encuentra la DataBase asi como los Reportes. El asunto es que tengo dos tipos de reportes, 1- los que vienes nativos el CRM y 2- Unos creados por nosotros mismos. El hecho es que hace un par de dias los resportes propios de CRM dejaron de funcionar, los otros funcionan sin problemas..

    En el IE me reporta este error: REPORTING ERROR, the report cannot be displayed, try thsi action later..........blabla
    En el visor de eventos de Windows tengo dos errores que aparecen cada vez que intento accesar los reportes nativos desde cualquier maquina, aqui los detallo:


    1---Error con ASP.net 2.0
         Event id 1309

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 20/08/2009 10:06:29 a.m.
    Event time (UTC): 20/08/2009 05:06:29 p.m.
    Event ID: be28feb727dd40aebcf8bc991adda4db
    Event sequence: 456
    Event occurrence: 2
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/ROOT-1-128952604709462804
        Trust level: Full
        Application Virtual Path: /
        Application Path: c:\inetpub\wwwroot\
        Machine name: XXXXXXX
     
    Process information:
        Process ID: 5192
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: CrmReportingException
        Exception message: An error has occurred during report processing. (rsProcessingAborted)
     
    Request information:
        Request URL: http://crm4.artinsoft.net/ArtinSoftCorporation/CRMReports/rsviewer/reportviewer.aspx
        Request path: /ArtinSoftCorporation/CRMReports/rsviewer/reportviewer.aspx
        User host address: 192.168.X.XX
        User: XXXXXXX\XXXXX
        Is authenticated: True
        Authentication Type: Negotiate
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 1
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:    at Microsoft.Crm.Web.Reporting.SrsReportViewer.SetExecutionCredentials(ServerReport report)
       at Microsoft.Crm.Web.Reporting.SrsReportViewer.ConfigurePage()
       at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
     
     

    2----MSCRMReporting
           Event id 19969

    Web service request SetDataSourceCredentials to Report Server http://aiscrit26/reportserver failed with SoapException. Error: An error has occurred during report processing. (rsProcessingAborted)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Agradeceria mucho la ayuda que me puedan dar.

    Saludos






    jueves, 20 de agosto de 2009 17:14

Respuestas

Todas las respuestas

  • ¿ Did you try execute PublishReports.exe from Tools directory ?
    • Propuesto como respuesta David Martinez Fresneda viernes, 21 de agosto de 2009 11:59
    • Marcado como respuesta maetiko viernes, 21 de agosto de 2009 14:35
    viernes, 21 de agosto de 2009 6:21
  • Not Yet, but i have never use this tool before and reports work great it's weird........

    How can i use this tool.

    Thanks...
    viernes, 21 de agosto de 2009 15:56
  • Hi DAvid, i'm trying to execute the Report tool, BUT there's a problem with My Organization Name, I'm completely sure about the Company Name and when i try to run it, i received this message, please check it out:



    C:\Program Files\Microsoft CRM\Tools>PublishReports.exe "Company_Name"

    Unhandled Exception: Microsoft.Crm.CrmConfigObjectNotFoundException: Organizatio
    n With Name = Company_Name Does Not Exist
       at Microsoft.Crm.ServerLocatorService.GetOrganizationIdByNameFromDatabase(Str
    ing organizationName)
       at Microsoft.Crm.ServerLocatorService.GetOrganizationId(String organizationNa
    me)
       at Microsoft.Crm.LocatorService.GetOrganizationId(String organizationName)
       at Microsoft.Crm.Reporting.Publish.PublishReports.Main(String[] args)


    Thanks...
    viernes, 21 de agosto de 2009 17:40
  • Hola, "maetiko"

    Por el uso de las comillas (") tal vez estés probando con el DisplayName en lugar del nombre de la base de datos. Tu nombre de organización no debería contener espacios, acentos etc.

    Saludos

    Daniel - http://crmadiario.blogspot.com
    martes, 1 de septiembre de 2009 7:01