none
Informe Pedido RRS feed

  • Pregunta

  • Hola, buenas tardes,

    Tengo un rpoblema con un *.rdl, ya que cuando lo agrego en los informes como "nuevo" "desde archivo",  no permite ejecutarse el resource, aun cuando configure mis datos compartidos con la base de datos de Sql del Server donde esta instalada la Bse de Datos de CRM2011.

    En la imagen 1 muestro el formatod e fault que deseo usar.

    En la imagen 2 el error cuando quiero utilizar el Informe que cree.

    Como siempre agradezco su ayuda.

    Saludos.


    Raul Fuentes R. Soporte y Servicio Técnico en Sistemas y Seguridad Eléctronica

    miércoles, 20 de marzo de 2013 18:59

Respuestas

  • Hola Raul,

    Lo primero que yo haría sería.

    1. Entrar al administrador de reportes (http://<servidor>/Rerports

    2. Dale clic a Mostrar detalles (superior derecha), de ahí busca la carpeta de <ORG>_MSCRM (si son reprotes hehoc por ti) o CustomReport (si son los del crm)

    3. Dali clic al nombre y ejecuta el reporte. Si no funciona, puede ser por dos factores

       a. Que tu source este mal y para cambiarlo lo que debes de hacer es, retorcer hasta donde se te mostraban todos los reportes, luego clic en propiedades/orígenes de datos ahí configura tu source y/o refrencia tu reporte a un source ya existente. Luego ejecuta nuevamente el reporte y si funciona .. ya esta arreglado

       b. Tu sentencia SQL esta mal, copia y pega la sentencia en el analizador de consultas, ejecútalo y corrige lo que puede estar mal.

    Si te funiona ejecutando tu report en el servidor, no debería de fallar en el crm.


    Salu2 Atilin | http://www.dexrm.com

    jueves, 21 de marzo de 2013 9:13

Todas las respuestas

  • Hola Raul, revisa este articulo a ver si te sirve: http://support.microsoft.com/kb/946585?wa=wsignin1.0

    revisa tambien que la conexion que utilices sea conectandose a la base de datos con autenticacion de windows integrada (y con las FilteredViews).

    Si es un CRM online, los reports debes hacerlos a traves de consultas "FetchXml" como explica este articulo: http://www.dynamicscrmtrickbag.com/2011/05/12/custom-ssrs-reports-for-dynamics-crm-2011-online/

    un saludo,


    Demian Adolfo Raschkovan Blog: http://crmtoall.blogspot.com If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    jueves, 21 de marzo de 2013 7:36
    Moderador
  • Hola Raul,

    Lo primero que yo haría sería.

    1. Entrar al administrador de reportes (http://<servidor>/Rerports

    2. Dale clic a Mostrar detalles (superior derecha), de ahí busca la carpeta de <ORG>_MSCRM (si son reprotes hehoc por ti) o CustomReport (si son los del crm)

    3. Dali clic al nombre y ejecuta el reporte. Si no funciona, puede ser por dos factores

       a. Que tu source este mal y para cambiarlo lo que debes de hacer es, retorcer hasta donde se te mostraban todos los reportes, luego clic en propiedades/orígenes de datos ahí configura tu source y/o refrencia tu reporte a un source ya existente. Luego ejecuta nuevamente el reporte y si funciona .. ya esta arreglado

       b. Tu sentencia SQL esta mal, copia y pega la sentencia en el analizador de consultas, ejecútalo y corrige lo que puede estar mal.

    Si te funiona ejecutando tu report en el servidor, no debería de fallar en el crm.


    Salu2 Atilin | http://www.dexrm.com

    jueves, 21 de marzo de 2013 9:13