Can't install Songsmith because of Net 3.0 Framework (which includes WPF)


  • I am using Vista with Net 3.0 Framework. (Also 3.5 and 4.0) 

    I tried all repairs and other suggestions from forums.

    But it didn't help.


    01 Juni 2011 11:46

Semua Balasan

  • I just found out about Songsmith so I have not installed it yet. But I do have an idea. Have you checked the Event Viewer to find specific errors? I found this while looking for a version of WPF that could be installed aside from all unnecessary parts of .NET since you have it already. and If that doesnt work, at least you will have another source using those sites to help solve your issue.

    Good luck.



    10 Juli 2011 5:07
  • I'm having the same problem on Vista Basic SP2.  I had .NET 1.5, 3.5 and even installed 4 and still got the error.  I finally removed all versions and attempted to install 3.0 from the link that Songsmith creates.  However, the installer stops and says I must use the programs and features in control panel to configure it.  I go into programs and features in control panel and check all boxes under .NET 3.0 and still Songsmith says I need .NET 3.0.

    26 Juli 2011 4:27