none
Configuration Error

    Pertanyaan

  • Hi, 

    Guys please help me about about this error i cant understand what to do...? 

    <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider,

    28 September 2018 11:17

Semua Balasan

  • You should indicate more than simply what has been posted as there is no context to it. For instance, is this a new or old project, did it work at one time, what type of project is it, more details will get you assistance while less means we must ask you questions.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    28 September 2018 11:47
  • This looks like it is coming from a web.config file. In a web app you can configure what languages your views support. For each one you have to have this entry to associate the language with the compiler to use so the runtime can compile the underlying view code appropriately. Note that in your snippet the XML isn't fully provided. If that were all the XML then you'd get the error you mention.

    For ASP.NET applications please post your question in the ASP.NET forums.


    Michael Taylor http://www.michaeltaylorp3.net

    28 September 2018 14:36
  • Looks like the version mentioned in the web.config is not matching, please check.

    <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4"
        type="Microsoft.CSharp.CSharpCodeProvider,System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
       <providerOption name="CompilerVersion" value="v4.0"/>
       <providerOption name="WarnAsError" value="false"/>
      </compiler>

    -------------------------------------

    If this resolve your issue, please mark it as answered

    28 September 2018 14:42
  • Hello, 

    most likely, the C# v4.0 compiler not available for your IIS user account.

    Or

    there are no specified compiler version at all.


    Sincerely, Highly skilled coding monkey.

    28 September 2018 16:00