none
Crystal Report not showing the dynamic image when passing the image URL via variable

    Pertanyaan

  • Im developing a software and the crystal report is acting strange.

    I have the follow situation:

    I have a image URL from the disk in a variable in C#. In the report there's a parameter value for the variable. I have a picture with a formula set in this parameter in the report.

    When I set the image URL for the parameter manually, the image shows correctly. Like this:

    report1.SetParameterValue("pctImage", "D:\PRP System\DB\img1.jpg");

    But when I use a variable with the same string value (I checked the string value many and many times and it's the same value as the above) the image just doesn't show.

    string img = "D:\\PRP System\\BD\\modelos\\" + obj1.picture.Replace("D:/PRP System/BD/modelos/", "");
    report1.SetParameterValue("pctImage", img);

    Obj1 has the URL for the image with the name of it.

    I don't understand why this is happening.

    Selasa, 30 Oktober 2018 14.21

Semua Balasan

  • Hi Pharaoh_fate,

    This forum discusses and asks questions about the C# programming language, since your issue is more related to Crystal Report, I would suggest that you could post your issue on Crystal Report forum for suitable support.

    https://forums.asp.net/76.aspx/1?Crystal+Reports

    Thanks for your understanding.

    Best regards,

    Zhanglong


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Rabu, 31 Oktober 2018 01.25