none
add windows printer connection doesn't work on slow logins

    Pertanyaan

  • If I run something like this on login with a new profile:

    Set objNetwork = CreateObject("WScript.Network") 
    objNetwork.AddWindowsPrinterConnection "\\server\printer"

    and the login is slow (over a minute?), the printer never appears.  Is there some kind of timeout (smb?) that I can make longer?



    • Diedit oleh JS2010 Senin, 02 April 2018 17.30
    • Dipindahkan oleh Bill_Stewart Rabu, 30 Mei 2018 19.26 Off-topic
    Senin, 02 April 2018 17.01

Semua Balasan

  • Printer connections should be done by Group Policy Preferences and not via a login script.  Login scripts in current Windows are delayed by as much as 5 minutes.  GP assigned printers are not delayed.

    Post you issue in the GP forum.  The script is not the cause or the solution.


    \_(ツ)_/

    Senin, 02 April 2018 17.10
  • The same thing happens with group policy.

    Senin, 02 April 2018 17.16
  • The same thing happens with group policy.

    Then it is clearly not a scripting issue.  Post in GP forum or contact MS Support form help.

    If you don't use GP printer deployment correctly then it will not work.


    \_(ツ)_/

    Senin, 02 April 2018 17.19
  • This turned out to be a conflict with Client-Side Rendering introduced in Server 2008, and deleting profiles.  It didn't help that the Print Spooler now listens on a random port.  Maybe not directly related to scripting, but it could interest them.


    • Diedit oleh JS2010 Rabu, 30 Mei 2018 19.30
    Rabu, 30 Mei 2018 19.30