none
Problema ribbon outlook 2010 e CRM 2011 - timeout / 'IsRibbonDataReadyOutlook' args '' failed to execute the function

    Domanda

  • L'add-in del CRM 2011 non funziona con outlook.

    Nella barra in alto compare l'errore: In attesa che una pagina venga recuperata da un server CRM...

    Quando si clicca su una scheda per vederla/modificarla, compare "E' in corso il caramento della pagina Wed da un server CRM", dopo parecchi minuti va in timeout.

    Abilitando i log si ripete all'infinito il seguente errore:

    ExecuteScriptFunction 'IsRibbonDataReadyOutlook' args ''

    ExecuteScriptFunction 'IsRibbonDataReadyOutlook' args '' failed to execute the function because it does not exist in the page at location http://name-machine:5555/Myname/_root/stage.aspx?id=&url=SiteMapNavPage.aspx&ver=63438193486943

    Come posso risolvere?

    martedì 12 aprile 2011 08:47

Risposte

Tutte le risposte

  • Potrebbero essere tante cose...

    1) anche se potrà sembrarti banale, controlla che il web client funzioni correttamente
    2) Tieni presente che siamo ancora in RTM e quindi è normale che ci sia ancora qualche "problemino"
    3) Ti consiglio di re-installare SQL CE 3.5 verificandone correttamente la versione (.8082) - puoi verificarlo dal pannello di controllo
    4) Cosa intendi per "abilitando i log"??

    Saluti

    G


    Giorgio Garcia-Agreda MVP Microsoft Dynamics CRM
    giovedì 14 aprile 2011 10:41
    Moderatore
  • 1) funziona alla perfezione

    3) già fatto, ed era già la versione (.8082).

    4) Ho abilitato i trace (Diagnostica, Risoluzione dei problemi avanzata, Analisi). L'errore stà li dentro, ma ovviamente non da indicazioni utili.

    Il problema si presenta su tutte le macchine con Outlook provate (4-5, alcune configurare diversamente)

    Non è chiaro se il problema sia a livello client o a livello server.

    giovedì 14 aprile 2011 10:47
  • Ti dovrei fare un milione di domande per cercare di capire se è un problema Client o Server...

    1) E' un upgrade dalla V4 o una clean installation?? (Server e Client)
    2) Se Upgrade, che tipo di personalizzazioni c'erano nella V4? Qualcosa in ISV.Config???
    3) A parte i Ribbon... che non vengono caricati, succede qualcos'altro o si impalla tutto??

    Dammi queste 2-3 risposte così verifico, altrimenti scalo sul team di prodotto per avere qualche info in +.

    Regards

    Giorgio


    Giorgio Garcia-Agreda MVP Microsoft Dynamics CRM
    giovedì 14 aprile 2011 20:54
    Moderatore
  • 1) clean installation sia server che client

    3) in outlook, si connette e si vedono i dati da "dentro" outlook. (es. vado su servizi, contatti, seleziono un contatto e vedo il contenuto).

    Se però faccio doppio click sul contatto, per modificarlo/aprilo, compare la classica schermata "E' in corso il caramento della pagina Wed da un server CRM", e dopo parecchi minuti (anche 10 minuti) va in timeout.

    Se poi tenti di nuovo di fare doppio click su un contatto, una volta andato in timeout, non succede più nulla.

    Il ribbon in alto uguale, in outlook compare "In attesa che una pagina venga recuperata da un server CRM..." e dopo n minuti va in timeout.

     

    Grazie per il supporto.

    Saluti,

    Paolo.

    venerdì 15 aprile 2011 07:33
  • Ciao Paolo,

    stranamente questo problema è successo anche a me ed ho notato che accadeva esclusivamente quando ibernavo il mio notebook, dopo averlo utilizzato non essendomi autenticato al dominio.

    Semplicemente disconnettendo la sessione e ri-eseguendo il logon del mio utente tutto è ripreso a funzionare normalmente.

    Ho notato, in ogni caso, che anche performance molto basse del server CRM possono condizionare "l'accesso" del client di Outlook e relativa sincronizzazione con il server.

    Saluti


    Giorgio Garcia-Agreda MVP Microsoft Dynamics CRM
    mercoledì 18 maggio 2011 11:01
    Moderatore
  • Putroppo questo bug, nel mio caso, è fisso. Succede sempre.

    Hai qualche indicazione utile da darmi? Forse è colpa di qualche impostazione del dominio?

    A parte le traces e un analizzatore del traffico di rete, c'è qualche altro strumento utile per trovare la causa del problema?

     

    Ho già reintallato tutto il server crm e outlook da zero, ma il problema persiste.

     

    Saluti,

    Paolo.

    giovedì 19 maggio 2011 07:28
  • Prova ad effettuare il download dell'Update Rollup 1, sono state fixate diverse cose tra cui anche alcune issues relative ai Ribbon...

    http://blogs.msdn.com/b/crminthefield/archive/2011/03/24/podcast-and-overview-microsoft-dynamics-crm-2011-update-rollup-1.aspx

     

    Saluti

    G


    Giorgio Garcia-Agreda MVP Microsoft Dynamics CRM
    martedì 30 agosto 2011 21:09
    Moderatore