none
BSOD e crash sporadici in VDI

    Domanda

  • Buongiorno,

    ho un VDI (l'unico su tanti) che saltuariamente va in bluescreen e si riavvia. OS Win 7 SP1.
    LA VM è stata ricreata già 4 volte, ma continua ad accadere, in fase di regolare utilizzo.
    Questa è una analisi del dump e l'errore negli eventi.
    Any ideas?

    Grazie

    Qui gli screen, non mi fa aggiungere immagini.

    https://answers.microsoft.com/it-it/windows/forum/windows_7-performance/bsod-e-crash-sporadici-in-vdi/05f35034-c4c4-4346-b576-02a5fa120f7b?tm=1538731688248

    venerdì 5 ottobre 2018 11:11

Tutte le risposte

  • Ciao Demamed.

    Il bug check 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED) indica che un thread di sistema ha generato un'eccezione che non è stata intercettata; il valore del primo parametro (0xC0000005, STATUS_ACCESS_VIOLATION) come riportato nel tuo screenshot indica una violazione di accesso alla memoria.
    Per capire cosa abbia causato il crash (si verifica in modo del tutto casuale o sei in grado di individuare precisamente le circostanze in cui il problema appare?) è necessario analizzare il file .DMP creato da Windows nel momento in cui si è verificato il problema: caricalo sul tuo OneDrive, condividilo pubblicamente e scrivi qui l'URL, in modo che possiamo analizzarlo e cercare di suggerirti una soluzione.

    Ciao.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    sabato 6 ottobre 2018 22:32
  • Ciao Luigi,

    rispondo anche qui con il link così eventualmente possono vederlo anche altri

    https://1drv.ms/u/s!AiITT3pptFsxlQLKk8qbZx_jWp8O

    Grazie!


    • Modificato Demamed lunedì 8 ottobre 2018 07:32
    lunedì 8 ottobre 2018 07:20
  • Scarica anche WhosCrashed : http://www.resplendence.com/whocrashed

    Potrà darti una mano sicuramente nell'individuazione del problema.
    lunedì 8 ottobre 2018 07:33
  • Questa VDI gira su Hyper-V?Quando dici che la VM viene ricreata, intendi come child del template o proprio da zero?
    lunedì 8 ottobre 2018 11:10
    Moderatore
  • Ciao Luigi,

    rispondo anche qui con il link così eventualmente possono vederlo anche altri

    https://1drv.ms/u/s!AiITT3pptFsxlQLKk8qbZx_jWp8O

    Grazie!


    Il faulting process è ntkrnlmp.exe, il kernel del sistema operativo: l'indicazione è un po' generica, visto che il dump dello stack non evidenzia alcun driver in particolare come possibile responsabile del crash.
    Come è stata ricreata la VDI? Hai usato un template uguale a quello delle altri che funzionano correttamente o è stata ricostruita manualmente da zero?

    Ciao.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    lunedì 8 ottobre 2018 11:18
  • LA VDI è stata ricreata utilizzando la Golden Image da cui sono state create tutte le altre. Ed è l'unica a presentare questa anomalia.

    La VM gira su VMWare.

    All'utente che la utilizza è parso che accade più spesso nell'utilizzo di Acrobat.

    lunedì 8 ottobre 2018 14:03
  • LA VDI è stata ricreata utilizzando la Golden Image da cui sono state create tutte le altre. Ed è l'unica a presentare questa anomalia.

    La VM gira su VMWare.

    All'utente che la utilizza è parso che accade più spesso nell'utilizzo di Acrobat.

    Anche se mi sembra strano che Acrobat possa tirare giù il sistema, le versioni di Acrobat sono allineate tra tutte le VDI o ci sono delle differenze?

    Ciao.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    lunedì 8 ottobre 2018 14:35
  • Tutte le VDI hanno la 19.008.20071.

    Ho aggiornato poco fa solo quella VDI alla 19.008.20074.

    Sono d'accordo sul fatto che è improbabile che Acrobat possa riuscire a creare una eccezione tale da buttare giù il s.o.

    Ora sono 3 giorni che non capita, ma è già successo che durasse anche una settimana. Per esempio, gli ultimi 4 sono: 24 settembre, 1 ottobre, 3 ottobre, 5 ottobre.

    Non riesco a capire quale azione possa essere fatta che generi una simile reazione.

    Ps. Forse ero distratto, ma il sistema operativo non è Win 7 SP1 bensì Win 2008R2 SP1

    lunedì 8 ottobre 2018 14:53
  • Tutte le VDI hanno la 19.008.20071.

    Ho aggiornato poco fa solo quella VDI alla 19.008.20074.

    Sono d'accordo sul fatto che è improbabile che Acrobat possa riuscire a creare una eccezione tale da buttare giù il s.o.

    Ora sono 3 giorni che non capita, ma è già successo che durasse anche una settimana. Per esempio, gli ultimi 4 sono: 24 settembre, 1 ottobre, 3 ottobre, 5 ottobre.

    Non riesco a capire quale azione possa essere fatta che generi una simile reazione.

    Ps. Forse ero distratto, ma il sistema operativo non è Win 7 SP1 bensì Win 2008R2 SP1

    La configurazione software (=driver) è esattamente uguale a quella di tutte le altre VDI che funzionano correttamente?
    Tieni sotto controllo questa macchina virtuale e vedi se il problema si ripresenta.

    Ciao.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    lunedì 8 ottobre 2018 15:24
  • Si, la configurazione è identica, i driver sono gli stessi.

    L'unico software in più è PDFCreator. 

    Eventualmente se dovesse ricapitare provo a monitorare senza l'utilizzo di quest'ultimo.

    Ci aggiorniamo, nel caso

    Grazie :)

    lunedì 8 ottobre 2018 15:42
  • Buongiorno,

    puntualmente l'anomalia si è ripresentata, in fase di apertura di un pdf allegato ad una mail.

    https://1drv.ms/u/s!AiITT3pptFsxlQMQnjJHdWuIv96_

    Qualche idea?

    Grazie

    martedì 9 ottobre 2018 10:13
  • Visto che il problema sembrerebbe proprio a livello di memoria, penso che il maggior indagato sia proprio VMWare.
    Sicuro che la macchina virtuale è esattamente allineata ad altre VM in esecuzione sullo stesso host che risultano funzionanti?
    Non considerare VM generate dalla stessa immagine ma in esecuzione su host differenti.
    martedì 9 ottobre 2018 14:22
    Moderatore
  • Buongiorno,

    puntualmente l'anomalia si è ripresentata, in fase di apertura di un pdf allegato ad una mail.

    https://1drv.ms/u/s!AiITT3pptFsxlQMQnjJHdWuIv96_

    Qualche idea?

    Grazie

    Il problema registrato nel file .DMP è sempre lo stesso: a questo punto il dubbio che sorge è che la causa non sia nella VDI ma nell'infrastruttura di virtualizzazione sottostante.
    La VM è esattamente allineata a tutte le altre funzionanti sullo stesso hosto fisico?

    Ciao.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    martedì 9 ottobre 2018 14:58
  • Ciao,

    purtroppo non so darti con certezza questa informazione perché queste VM sono sotto Hypervisor del nostro provider. Sicuramente però ce ne sono altre e sono tutte uguali, e nessun altro ha problemi.

    La versione usata di esxi è la 6, mentre la versione di horizon è 4.7.0.11074.

    mercoledì 10 ottobre 2018 10:03
  • A mio parere dovresti coinvolgere il tuo provider aprendo un ticket. La questione va approfondita lato infrastruttura VDI, sicuramente non è una problematica risolvibile agendo lato guest sulla specifica VM. Come dicevamo il tuo errore è molto generico e relativo alla gestione della memoria.
    Per caso hai eseguito qualche modifica sulla RAM allocata?
    Ti consiglio nel caso anche di chiedere direttamente nel forum VMware, più indicato per il tuo tipo di problematica:
    https://communities.vmware.com/community/vmtn/horizon/content?filterID=contentstatus%5Bpublished%5D%7Eobjecttype%7Eobjecttype%5Bthread%5D
    mercoledì 10 ottobre 2018 19:53
    Moderatore