none
error installing, updating, or even viewing powershell modules RRS feed

  • Pergunta

  • I'm hoping someone can help. Just this week i started receiving an error any time i try to install or update powershell modules. The primary message is:

    Unable to find module providers (PowerShellGet)

    So evidently i no longer have PowerShellGet.  If i try to install, i get the same error:
    Install-Module -Name PowerShellGet -ForcePackageManagement\Install-Package : Unable to find module providers (PowerShellGet).

    Also when trying to register the repository:
    >Register-PSRepository -DefaultPackageManagement\Register-PackageSource : Unable to find module providers (PowerShellGet).

    And also with get-psrepository:
    >Get-PSRepositoryPackageManagement\Get-PackageSource : Unable to find module providers (PowerShellGet).

    I can get a list of package providers but atempting to add any additional providers produces the same error:
    >Get-PackageProvider -ListAvailableName                     Version          DynamicOptions----                     -------          --------------NuGet                    2.8.5.208        Destination, ExcludeVersion, Scope, SkipDependencies, Headers, FilterOnTag...

    I found others with the same issue but it seams they've all benn able to resolve this by disabling FIPS, which is already disabled for me both in the local security policy and in the registry:
    >Get-Item HKLM:\System\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy   Hive: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LsaName                           Property----                           --------FipsAlgorithmPolicy            Enabled : 0

    I'm stuck and am hoping someone in these forms can help. Thanks.

    sexta-feira, 22 de maio de 2020 19:46

Respostas

Todas as Respostas