none
Vista Index not rebuilding RRS feed

  • Pergunta

  • Hi all,

    I have Vista ulitmate. I clicked on rebuild my index in the indexing options view (2months ago). At present there is no record in the indexed items of files that are in my indexing locations. only new files are added. From the vista start menu I can also access the via quicksearch the start menu programs, but all the old files in the index location directories are not indexed, even after 2 months. I even left my computer on in a new boot state without any user activity to see if that will not force help the building of the index.

    Question: is there a way like in WDS 3.01 to force vista to build index now? Or a workaround?

    Thanks in advance

    segunda-feira, 19 de março de 2007 13:29

Respostas

  • Also is this a desktop or laptop. We stop crawling on low battery power. Can you go into your control panel and see if the OS is incorrectly thinks that your machine had a battery. Check to make sure your power configuration is set to max power.
    terça-feira, 20 de março de 2007 23:26
  • The problem was Vista running in a power saving mode. In the power profiles setting the indexing setting was set to power saver. This seemed to stop the crawling as Eric said.

    Thanks for the advice - the index was built in 15 minutes

    segunda-feira, 26 de março de 2007 16:40

Todas as Respostas

  • Try to rebuild your index again and wait till the index finishes and report back wether you can get all your files indexed or not.
    terça-feira, 20 de março de 2007 20:03
  • Also is this a desktop or laptop. We stop crawling on low battery power. Can you go into your control panel and see if the OS is incorrectly thinks that your machine had a battery. Check to make sure your power configuration is set to max power.
    terça-feira, 20 de março de 2007 23:26
  • Dear David and Eric,

    Thanks for the advice. I tried to rebuild the Index but even after a whole week, nothing has changed. The indexing service only seems to index files that I have opened or saved since the index rebuild.

    Secondly, I am using a desktop system which is running in power saving mode. I goes into standby after 120 minutes and hibernate after 500 minutes. Using a custom profile based on the power saving profile.

    System: Intel Conroe 2 2700
    2 GB Ram
    1 WD 300 GB harddrive
    1 Maxton 250 GB harddrive
    Asus P5B-deluxe Motherboard
    Asus EN 7900 GT Nvidia Video card

    Hope this points in the right direction...

    I really hope you can help me sort this, I almost want to go back to XP and WDS 3.01 which worked like a dream.

    Thanx


    segunda-feira, 26 de março de 2007 09:04
  • On your power options, what is the Search and Indexing settings? How many items do you currently have indexed?
    segunda-feira, 26 de março de 2007 16:38
  • The problem was Vista running in a power saving mode. In the power profiles setting the indexing setting was set to power saver. This seemed to stop the crawling as Eric said.

    Thanks for the advice - the index was built in 15 minutes

    segunda-feira, 26 de março de 2007 16:40
  • I'm glad I found this thread. I've been having this issue for two months without resolution. The best I've done when rebuilding the index is 17 items indexed after two weeks. I have checked the above suggestions but no joy. The computer( desktop) does not sleep, hibernate, or suspend. When I open Indexing Options I always see the message"Indexing speed is reduced due to user activity." My system is Vista Ultimate x86, Intel x6800, 2gb ram, 2 300 gb sata hard drives configured as RAID 0 , Nvidia 7950gtx2. Any suggestions would be appreciated.
    terça-feira, 27 de março de 2007 23:50
  • Jim,

    It is not the suspend or hibernate itself that stops the crawling from my own experience but the advanced power saving features. Try this:

    In the search window type in : power to get to the power options.  Select the active power profile and go to the advance settings for this profile. In the advance settings look for the indexing tree node and make sure it is NOT on power saver - that forces the crawler to stop if I understood it correclty. I agree it could be better described in the vista help settings on the power options (there are none on the advance power settings... or none that I could find) but Eric's post seemed to point me in the right direction)

    I hope this helps - your problems sound siimilar to mine and that could be the case. Alternatively, just set your computer's power setting to the default high performance setting, but then you loose out on the power saving, as a quick solution.
    quarta-feira, 28 de março de 2007 20:16
  • Koos,

    Thanks for the reply. Unfortunately, I use the high performance power mode and in the advanced settings Search and Indexing is set to High Performance. I have tried every suggestion in every thread in this forum without success. Of the four computers I have Vista installed on this one is the only one I can't get search to work on. I might consider a reinstall if I can convince myself that losing the three months I spent getting this computer exactly the way I want it won't be so bad.

    quarta-feira, 28 de março de 2007 23:52
  • Fixed! I did a repair install of vista and indexing works now.
    quinta-feira, 29 de março de 2007 14:34
  • According to Windows Vista Help info, the Vista desktop search indexer can't be disabled. In a news story today headlined "Google Mulls Microsoft Antitrust Fight", Google is complaining that this is an abuse of monoply power. The story says that "Microsoft denied the accusations, saying that its own search indexing could be turned off, although with some difficulty".

    http://www.pcworld.com/article/id,132746-c,microsoftantitrustcase/article.html

     

    I'd like to know how you turn it off! My harddrive grinds and grinds for several minutes, a number of times a day, and in the middle of the night, for no good reason. I strongly suspect the search indexer, even though I told it to index nothing. (I elimated all non-OS suspects by uninstalling them, including the Google desktop indexer).

     

    I've also had the problem discusssed in this thread: I changed the power saving options to save power on a desktop machine and it totally destroyed file searching. Wow. After having now changed it back and asked for a complete rebuild of the index, I'm now in a state where the contents of newly created files or even renamed files come up on searches alright, but the contents of files created during the earlier period are still not being reported by the searcher.

     

    By the way here's another problem with search in Vista: In the Control Panel pick "Taskbar and Start Menu", then pick "Start Menu", then pick Customize, then scroll down to "Search files". Then you can pick either "Search this user's files" OR "Search entire index". This option purports to set the default behavior for what is and isn't searched. The default setting is to search "this user's files" only. I wasn't able to find anything explicit about it in Help. The option isn't offered from Folders-->SearchOptions. It's another item demonstrating that Vista searching and indexing is badly thought out and badly implemented.

     

    What I want is a different searcher/indexer. So, can somebody please tell me how the one in Vista can be turned off.

     

     

    segunda-feira, 11 de junho de 2007 18:18
  • It didn't work for me. I added and removed folders from the Indexing list. When I click on rebuild index it pauses for half a second then returns to the menu.

    the counter always stays at 0 and says Indexing complete even though I just included a very large folder with many files in it.

     

    When I try to search in outlook contacts it acts as if I have no contacts at all. I made sure .pdf was included in the indexing file extensions.

     

    Someone suggested repairing vista so I used the Vista install disk and repaired the OS to make sure everything was fine. It keeps assuring me everything is working properly but I get blue screens all the time now. More often as time goes on. I can turn on my laptop and walk away for an hour. several times I've returned to find it blue screened. Once sitting here after I had logged in i watched it. i don't have a screen saver so i know that’s not the trigger. it was at the desktop and went blue. I wonder if indexing is the problem but before I try to troubleshoot this issue I'd like to try and rebuild the index first.

     

    I would like to just restart the indexing from scratch. I suspect the file is corrupted somehow. Can I find and delete the index file? Where is it?

     

     

    segunda-feira, 11 de junho de 2007 18:57
  • I found out how to disable the indexing. It's explained at

    http://4sysops.com/?p=457

     

    The short of it is to click the taskbar's Startup button and type SERVICES in the search box. Then, in the presented list, you scroll to the "Windows Search" service, and right click it for its Properties.  Stop the service and set its startup property to Disable.

     

     

     

    segunda-feira, 11 de junho de 2007 22:36
  • Yep I have the same problem with indexing. I have everything on max power. Hibernation and suspend is disabled. Running Vista Ultimate 32-bit. I have tried to rebuild and restore default option, moving the index location, recopy gathrprm.txt and schema.txt files, and running SFC. I also tried the registry fix under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search. Changing MustRecovery to "0."

     

    I know a repair install would fix this, but there must be a way to fix this without doing this. Anyone have any ideas on this?

    quarta-feira, 13 de junho de 2007 05:52
  • Tried to rebuild the index but nothing happens. The status box shows 0 objects indexed.

    Checked all my power settings alternatives and can not find anything that should prevent indexing.

    I then pulled out the external power and the indexing started immediately. Inserting the external power again stops the indexing. Without doubt this problem has to do with the power setting handling.

    So indexing works when battery powered and not with external power. This is inverse to what expected.

     

    My Laptop is running the Acer Empowering Technology, I will try to disable it and see if this makes any difference.

    terça-feira, 30 de outubro de 2007 13:03
  • You have to make sure that the Search and Indexing power setting is set to High Performance. My best guess about what's happening is that your laptop automatically switches power profiles when it's plugged in or unplugged. Whatever power profile it's using when it's plugged in is probably set wrong. In Power Options control panel, go to Ediit plan settings for whatever power plan you are using, then go to "change advanced power settings." Make sure that under Search and Indexing the power setting is High Performance for both the case where you're on AC power and when you're on battery power.

     

    quarta-feira, 31 de outubro de 2007 20:04
  • I have been reading these posts, and everyone is saying the same thing.  Vista is not indexing.  Reply: check power settings.

    However, even with the power settings set properly, Vista is STILL NOT INDEXING.

    Can someone from Microsoft please respond to the posts on this thread and tell us whether there is a problem here that is fixable or not?
    terça-feira, 6 de novembro de 2007 13:31
  • I have Vista Ultimate with Office Professional. I’ve had this indexing failure problem for weeks. The following procedure finally fixed it for me. One or more steps may be unnecessary, but I will leave it for someone else to refine my procedure.

    1.       Uninstall Google Desktop (on the guess that its indexing function conflicted with Windows Indexing function – although I’m not sure, the problem might have started about the time I activated this feature).

    2.       Go to Control Panel -> Programs and Features -> Turn Windows features on or off -> Check Indexing Service -> OK (Don’t know if this was unchecked before uninstalling Google Desktop).

    3.       Go to Control Panel -> Indexing Options -> Advanced ->Index Settings Tab -> Restore Defaults -> OK (this will warn you that your current index will be destroyed and any customizations will be lost and that it might take  a long time to rebuild).

    4.       Restart Windows.

    5.       Go to Control Panel -> Indexing Options -> Advanced -> File Types Tab -> Check Extension “pst” and select radio button ”Index Properties and File Contents” -> OK (Don’t know if problem was already fixed  before this step).

    Good luck and have fun.

     

    sábado, 17 de novembro de 2007 12:24
  • TomJ54,

     

    The indexing feature that you turned on in steps 2-5 is the OLD indexing service from windows XP/2000, not the new updated version (e.g. "instant search") that Windows Vista has bundled in its windows software package.  The purpose for having that there is for backwards compatibility only, not to fix the current problem.  You just put an old Buick engine in your new BMW.

     

    Google desktop was not installed to begin with.

    domingo, 18 de novembro de 2007 05:32
  •  

     

    there was this piece of advice that i came across:

     

    http://www.neowin.net/forum/index.php?showtopic=613825

     

    in short:

     

    run->regedit

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager

    DisableBackoff = 1

    quinta-feira, 12 de junho de 2008 20:44
  • Awesome. Your suggestion helped me straightway.

    thanks

     

    segunda-feira, 30 de junho de 2008 12:45
  • I've had this problem too, and just solved it quite simply (I'm actually quite amazed at what solved it). 

     

    Start->Administrative Tools->Services

    Double Click "Windows Search"

    On the Log On Tab, make sure that "Allow service to interact with desktop" is UNCHECKED.  In my case, it was checked.

     

    Restart the service.

     

    That did it!

    • Sugerido como Resposta cshahmir sexta-feira, 1 de julho de 2011 06:17
    quinta-feira, 24 de julho de 2008 02:13
  • We've seen this problem a few times but have never tracked down how this setting was turned on. If the "allow service to interact with desktop" checkbox is checked, it will cause the indexer to not function properly. Do you have any idea how this setting was changed (it's not turned on by default)? Can you give us an idea of what software you have installed, especially in the antivirus/antimalware/security category?

    quinta-feira, 24 de julho de 2008 02:54
  • The system would not allow me to change DisableBackoff to 1.  It there a trick to updating this setting.  Or do you have any other suggestions?
    I've been fighting this for months and i keep rebuilding my index manually.  Based on the previous queries and replies, there does not seem to be a simple answer from Microsoft to resolve this issue.
    terça-feira, 4 de novembro de 2008 20:12
  •  Geoff18 wrote:

    I've had this problem too, and just solved it quite simply (I'm actually quite amazed at what solved it). 

     

    Start->Administrative Tools->Services

    Double Click "Windows Search"

    On the Log On Tab, make sure that "Allow service to interact with desktop" is UNCHECKED.  In my case, it was checked.

     

    Restart the service.

     

    That did it!

     

    Oh My God! Thank you very much mate! I was closed to suicide when I read this post. It solves my problem!

     

    Wink

    segunda-feira, 17 de novembro de 2008 14:28
  • In case anyone else has this issue, here's how to change the registry key.

    http://news.office-watch.com/t/n.aspx?a=596

    Essentially, run regedit as Administrator.

    Then give administrator permission to that registry key (the folder called Gathering Manager). I also had to make Administrator the owner.

    Finally, I was able to change the registry key.

    segunda-feira, 27 de junho de 2011 21:42