locked
Facing big problem with my tool RRS feed

  • Pergunta

  •  

    Dear all

    I am facing big problem with my tool that I was developed using visual Basic .NET

    The tool purpose is to access many Excel files and collect specific attribute and store it in MDB file, and creating reports for these attributes.

    The Toole is working correctly in some pcs but in other it give an error titled with form1, mention that could not load file or assembly “Microsoft.office.interop.Access”

    Please help me

    quarta-feira, 3 de setembro de 2008 10:18

Respostas

  • Hi Kareem,

    I guess maybe you should put this post to VB.net part of this forum.

    Do you mean after you published you application it only work on some PC but not the other.

    if so the following information maybe able to help you. I think it is because some PC does not have the assembly Microsoft.Ofice.interop.Access

    1) Double click on the application name on Visual Studio.
    2) Click on “Publish” tab.
    3) Click on the “Application Files” button
    4) Check which filename/reference/assembly that the error message said it is missing.
    5) On “Publish Status” select “Include”
    6) After you have included all the required reference. Click “OK”
    7) Finally, you can republish the application and check if it works.

    Hope this can help

    Good luck
    quarta-feira, 3 de setembro de 2008 10:38

Todas as Respostas

  • Hi Kareem,

    I guess maybe you should put this post to VB.net part of this forum.

    Do you mean after you published you application it only work on some PC but not the other.

    if so the following information maybe able to help you. I think it is because some PC does not have the assembly Microsoft.Ofice.interop.Access

    1) Double click on the application name on Visual Studio.
    2) Click on “Publish” tab.
    3) Click on the “Application Files” button
    4) Check which filename/reference/assembly that the error message said it is missing.
    5) On “Publish Status” select “Include”
    6) After you have included all the required reference. Click “OK”
    7) Finally, you can republish the application and check if it works.

    Hope this can help

    Good luck
    quarta-feira, 3 de setembro de 2008 10:38
  • Moved to VB forum.

    Regarding the assembly missing issue, can you check have you embed the required assembly in your deployment process? Or did you redistribute the Office Primary Interop Assemblies?

    Regards,
    Colt

    quinta-feira, 4 de setembro de 2008 03:21
  •  

    thank you all very much my problem had been solved ALHAMD LELAH

     

     

    sábado, 6 de setembro de 2008 11:52