WMI throws RPC server is unavailable when trying to connect to remote server.


  • I'm trying to make a WMI connection to a remote computer (Windows Server 2003 sp2) from a Windows Vista.

    I keep getting the infamous The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

    For testing I'm using WBEMTEST to connect to \\\root\cimv2 when I get the error.
    If I try to connect to the local computer instead of the remote it works, but I can't connect from Vista to Windows Server.

    I can remote desktop the server, and login using the same username and password I'm using for the local computer, is this enough?
    Both computers are not part of a domain, is it necessary ? How can I make them both be part of the same domain ?

    Both firewalls are off, I've read in dozens of places it can be a firewall thing, but they are off.

    I'm querying the port 135 on the remote computer, but it's responding as FILTERED.
    portqry -n -p tcp -e 135

    What else can I do? How can I enable port 135 for instance? The computers not being part of the same domain can be an issue ?

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole,EnableDCOM is Y  in both computers.
    I can ping the remote machine.
    Both Windows Firewalls are off.
    DCOM server process launcher service is on (both computers)
    WMI service, RPC and RPC locator services are on (both computers)

    Look forward to getting some pointers.
    Thanks a lot.

    Agustin Garzon.

    7 апреля 2009 г. 18:43

Все ответы

  • WMI doesn't use a fixed port by default.  Did you try opening up the port on the remote server like this:  And here:

    Since you don't have a domain you need to pass the credentials of an administrator (on the remote machine) when setting up the connection.  I don't suspect this is the problem (yet) because the server isn't even responding yet.

    If your machines are on different networks such that a router/firewall sits between them then you will likely have to punch a hole through the firewall for WMI.

    Michael Taylor - 4/8/09

    8 апреля 2009 г. 14:09
  • The computer A is Vista, computer B is W2k3. Different networks, computers physically distants.

    Computer B is a server with Windows Firewall disabled. Eventhough, I performed the Windows Firewall: Allow remote administration exception on the Standard and Domain profiles, just in case.

    I read there are 2 connections, one that goes from A to B, and one that goes from B to A only in asynchronous calls.
    I run
    DCOMCNFG on computer B and set Remote Launch and Remote Activation for Administrators, and Remote Access for the Anonymous logon.

    I would like to get an access denied error, but I keep getting the RPC server unavailable error.

    On computer A (Vista), I opened all the ports as suggested here:
    netsh advfirewall firewall add rule dir=in name="DCOM" program=%systemroot%\system32\svchost.exe service=rpcss action=allow protocol=TCP localport=135

    netsh advfirewall firewall add rule dir=in name ="WMI" program=%systemroot%\system32\svchost.exe service=winmgmt action = allow protocol=TCP localport=any

    netsh advfirewall firewall add rule dir=in name ="UnsecApp" program=%systemroot%\system32\wbem\unsecapp.exe action=allow

    netsh advfirewall firewall add rule dir=out name ="WMI_OUT" program=%systemroot%\system32\svchost.exe service=winmgmt action=allow protocol=TCP localport=any

    Computers are in different networks. Computer A is behind a firewall (Vista Firewall) and a router (WRT54G).

    Isn't there simpler tests I can run to see where lies the problem ? Like port querying ?

    When I query port 135 on target server it responds "filtered". When I run netstat -an | find ":135" it shows 4 results, the first is listening and the others are established
    . Is it good?

    Thanks for your help.

    Agustin Garzon.

    8 апреля 2009 г. 15:01
  • Run this Google query , the 1st two hits look like good troubleshooting guides.
    Hans Passant.
    8 апреля 2009 г. 20:16
  • Sorry, that google query throws a page full of purple links, seen them all.

    Will post the solution once I had found it.


    9 апреля 2009 г. 0:25