locked
[Office 2010, 2007, Excel] Excel Otomatik Veri Girişi.. RRS feed

  • Soru

  • Merhaba;

    Belirli aralıklarla Şahıslara kesilen "İdari Para Ceza Tutanakları"nı listelediğim bir excel çalışma sayfasında;

    Şahıslara ait T.C. no, Adres, Ad, Soyad vb bilgileri her seferinde ilgili sütunlara yazmamak için mesela en sabit veri olan T.C. girdiğimde o kişiye ait diğer bilgilerin ilgili sütunlara yazılmasını nasıl sağlayabilirim?

    9 Mart 2011 Çarşamba 10:12

Yanıtlar

  • Merhaba,

    Daha önce belirtiğim gibi Düşeyara işlevini kullanabilirsiniz. Kişilere ait bilgileri (25 kişi için) Sayfa3 adlı sayfaya yazdığınızı  ve birinci satırda A-E sutunlarında Kimlik No, Adı, Soyadı, Plaka No, Adresi şeklinde sütün başlıklarınızın olduğunu varsayarak başka bir sayfada A2 hücresine kimlik noyu yazdığınızda diğer bilgilerin gelmesi için;

    B2 hücresi için:
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;2;YANLIŞ)

    C2 hücresi için
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;3;YANLIŞ)

    D2 hücresi için
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;4;YANLIŞ)

    E2 hücresi için
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;5;YANLIŞ) formüllerini önerebilirim.


    Size yardımcı olabilmişsem mesaj içerisindeki "Yardımcı Olarak Oyla" üçgenine tıklayın.
    • Yanıt Olarak İşaretleyen Varta Biki 12 Mart 2011 Cumartesi 19:27
    11 Mart 2011 Cuma 21:06

Tüm Yanıtlar

  •  Merhaba,

    "...T.C. girdiğimde o kişiye ait diğer bilgilerin ilgili sütunlara yazılmasını ..." sağlamak için o kişilere ait diğer verilerin elinizde olması lazım. Vatandaşlık numarasını girerek kişilere ait diğer bilgilerin elde edilmesi olası değildir. Geçmişte bazı yöntemlerle Nüfus ve Vatandaşlık İşleri G.Md. veritabanından veri almak mümkündü ama artık bu yapılamıyor. Eğer bir dosyada veya çalıştığınız excel doşyasının başka bir sayfasında bu veriler var ise istediğinizi yapmak olasıdır.

    -Veriler harici bir doyada ise, excelin yerleşik işlevleri yerine VBA kullanmak daha doğru olur.

    - Veriler çalıştığınız excel doşyasının başka bir sayfasında ise Düşeyara işlevini kullanarak istediğinizi yapabilirsiniz. Bu işlevle ilgili olarak Excelin yardım menülerinde yeterli açıklama var. Ancak örneklerdeki virgül yerine noktalıvirgül kullanmalısınız. (Örneklerde neden virgül yazıldığını bilmiyorum! Yardım bölümündeki örneklerin tümünde durum böyle. Çeviri hatası mı??? Belki üstadlar bunu açıklarlar bizde yararlanırız.)

    Saygılar.


    Size yardımcı olabilmişsem mesaj içerisindeki "Yardımcı Olarak Oyla" üçgenine tıklayın.
    9 Mart 2011 Çarşamba 17:02
  • Cevap için teşekkür ederim. Durumu daha iyi izah etmem gerekiyor;

    Her hangi bir kurumun veri tabanından bağımsız olarak;

    Ceza kesilen kişiler aşağı yukarı hep aynı, (toplasanız yüz kişi civarında) Gerekli bilgilerde T.C. no, Ad Soyad, Aracı varsa aracın plakası ve adres. Bu verilerin herbiri ayrı bir sutuna yazılıyor. Ben kişilerin bu bilgilerini bir kere girebilirim. Gerekirse o listeye ekleme yada bilgilerdeki değişiklik nedeniyle düzeltme yapabilirim.

    Hiç değişmeyecek olan değer T.C. no olduğu için ben, bir kişiye ait T.C. yi ilgili sütuna girdiğimde (hatta otomatik tamamlama ile hepsini girmeye bile gerek kalmayabilir) diğer sütunların kayıtlı olan bilgilerle doldurulmasını istiyorum.

    Umarım daha iyi izah edebilmişimdir. Yardımcı olursanız sevinirim.

    10 Mart 2011 Perşembe 09:20
  • Merhaba,

    Daha önce belirtiğim gibi Düşeyara işlevini kullanabilirsiniz. Kişilere ait bilgileri (25 kişi için) Sayfa3 adlı sayfaya yazdığınızı  ve birinci satırda A-E sutunlarında Kimlik No, Adı, Soyadı, Plaka No, Adresi şeklinde sütün başlıklarınızın olduğunu varsayarak başka bir sayfada A2 hücresine kimlik noyu yazdığınızda diğer bilgilerin gelmesi için;

    B2 hücresi için:
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;2;YANLIŞ)

    C2 hücresi için
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;3;YANLIŞ)

    D2 hücresi için
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;4;YANLIŞ)

    E2 hücresi için
    =DÜŞEYARA(A2;Sayfa3!$A$1:$E$25;5;YANLIŞ) formüllerini önerebilirim.


    Size yardımcı olabilmişsem mesaj içerisindeki "Yardımcı Olarak Oyla" üçgenine tıklayın.
    • Yanıt Olarak İşaretleyen Varta Biki 12 Mart 2011 Cumartesi 19:27
    11 Mart 2011 Cuma 21:06
  • Teşekkür ederim.. Sorumun cevabı ve sorunumun çözümüdür. Şimdi, gerektiğinde değişiklik yapabilmek için o formülü anlamam gerekiyor.
    12 Mart 2011 Cumartesi 19:32